1

In Unity, while moving a window, its "shadow" moves first, then, when the mouse is released, it's actually moved to the desired position.

enter image description here

Is there a way to have the actual window moving, not its "shadow", while it's being "held" by the mouse?

Note that I changed the GUI from Gnome to Unity, and in Gnome the actual window is being moved.

--- Edit J+3 ---

I installed a fresh Ubuntu 22.04.1 with Unity on a new FS. And the windows move normally there, meaning the full window is moved / refreshed along the way. So that's possible!

Note that my account is on a separate FS, shared (mounted) by the 2 Ubuntus when they're on. And I removed the .config, .gnome, ... settings so that the new Ubuntu would have to recreate them.

                 old Ubuntu
               /
/home/myAccount
               \
                 new Ubuntu

After a while, I booted back to the original Ubuntu on the other FS, and, surprise, windows are moved the wrong way, same as before. I was expecting the new "good" config created by the new Ubuntu in my account would make the old Ubuntu, now using the new config, behave normally. Some "bad" settings must probably be in the system, not in my account.

And even more surprising: while I didn't change anything in the config of the old Ubuntu, just logged in and bye, it still managed to overwrite my config so that the new Ubuntu would now change its behavior! The new Ubuntu caught the "wrong" move pattern :(

Ok, still searching...

4
  • There definitely is a way, I see the full window move on my 14.04 unity setup. Unfortunately don't see any settings to affect this. On the bright side, performance is probably better not having to redraw the whole window so often.
    – ubfan1
    Sep 1 at 23:50
  • Confirming what @ubfan1 says on 16.04 Unity the whole window moves, not a former shadow of itself. On the bright side you get to see the original position and the new position with the shadow. Sep 2 at 1:20
  • @ubfan1 A few weeks ago I was still using Gnome and there was no performance issue having the full window move (my PC is recent). And Unity is lighter than Gnome...
    – Déjà vu
    Sep 2 at 3:18
  • @WinEunuuchs2Unix Not really a "bright side" in my opinion. The initial window hides whatever is under, and is in the way of finding the ideal "landing" position.
    – Déjà vu
    Sep 2 at 3:22

2 Answers 2

1

you can change the settings related to windows opacity/transparency using compizconfig-settings-manager explained in: How can I make my windows transparent

go to CompizConfig-Settings-Manager > Accessibility and check Opacity, Brightness and Saturation

then a plugin will be installed on your device and you can change the opacity of the window you're resizing by scrolling up and down

you may need to re login in case the plugin isn't active

2
  • Thanks but as you can see from my screenshot, I was already ccsm, and there is already an opacity setting without the extra-plugins. My goal is not changing the opacity, it's to have the full real window move, not its "shadow" when I drag a window. Anyway, +1 for the effort...
    – Déjà vu
    Sep 3 at 8:16
  • oops, I didn't pay enough attention sorry, thanks for the +1 @Déjàvu
    – Amirreza
    Sep 3 at 18:46
0

Ok, found the answer, after a lot of research and dconf dump / analysis.

Simply, the parameter lowgfx in dconf drives wether the low-graphics mode should be enabled, or no.

Mine was set (from dconf dump)

[com/canonical/unity]
lowgfx=true
...

By setting it to false,

gsettings set com.canonical.Unity lowgfx false

windows move now "normally".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.