4

Here is my experience. I installed 22.04 the installed Chrome which started to use something called "keyring" which completely messed the RDP feature.

So I reninstalled VM quickly and tried to use RDP without adding any other software.

  1. I ran apt upgrade
  2. enabled Settings - Sharing
  3. tried to connect from W11 into Hyper-V Ubuntu 22.04.01

this is what I got:

Try RDP from Windows again - this time it asks for password and the RDP window opens but with another error inside it:

enter image description here

systemctl --user status gnome-remote-desktop.service - shows a lot of errors (you need to read them side-by-side):

enter image description here

enter image description here

enter image description here

4 Answers 4

5

The integrated gnome-RDP-desktop-daemon has some specific "features" that can't be found anywhere else:

  1. It seems to be a user-process, only working if someone is logged in on the host... similar to some VNC implementations.
  2. If the screenlock activates, it is immediately switched off.
  3. If you switch an attached monitor off, it is immediately switched off.
  4. It can't be used for any headless Installation.

I wish they had announced or documented this at least. But, No! I suggest they program this service as any user would expect it to work. Otherwise, I recommend all Users to install the XRDP Daemon for a full functional Terminal-Service like this Remote Desktop XRDP install

0
2

This is a well known/documented bug in the Ubuntu 22.04 implementation of Wayland.

Further info here as a starting point: gnome-remote-desktop: Couldn't retrieve RDP username: Credentials not set - AND MORE

1

The error, that mstsc here shows is very generic. However, what seems to be clear is the following:

  1. The client is the one here disconnecting from the server
  2. The graphics pipeline ([MS-RDPEGFX]) is used.
  3. No frame is shown by mstsc.

There is a known bug in mstsc, that selecting a Color depth other than "32-bit", then using the graphics pipeline (which according to your logs successfully initialized (see the "CapsAdvertise" message)) fails, although the client accepted using the graphics pipeline.

The Color depth setting is only for ancient servers (WinXP era) and the graphics pipeline only uses 32-bit as colour format: https://docs.microsoft.com/en-us/openspecs/windows_protocols/ms-rdpegfx/80afb419-0cd5-49f8-8256-f77cc1787ec9

In the connecting screen of mstsc, go to the "Display" tab and under "Colors", select "Highest Quality (32 bit)". I think that this might be the issue here.

0

Not sure if your problem is related to mine: my Remmina client (on Ubuntu 22.04) would crash immediately upon connecting to "Screen Sharing" (on Ubuntu 22.04), where RDP is now the default screen sharing protocol.

This happened only after a valid password was provided.

My fix: change both client and screen-share host's "display server" from Wayland to Xorg... see this:

How to switch from the Wayland display server to Xorg X11 on Ubuntu 22.04

Bonus: this also fixed my broken drag-and-drop problems which I experienced when trying to drag a file out of a zip file with the Archive Manager.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .