I just finished installing Ubuntu 12.04 32-bit on my laptop and I'm having a hard time getting my graphic card drivers to work.

Jockey (the GUI for installing additional proprietary graphic drivers) always fails to successfully install either of the two driver options it proposes me with, which are:

  • ATI/AMD proprietary FGLRX graphics drivers (post-release updates)
  • ATI/AMD proprietary FGLRX graphics drivers

For both, it throws the following error message:

Sorry, installation of this driver failed. Please have a look at the log file for details: /var/log/jockey.log

The log file was a dead end, since I lack the brains to understand it. I can post it if needed.

I continued my investigation by checking if I could install the drivers using Aptitude and here is where it gets weird. The command 'apt-cache policy fglrx-updates' reveals that my system has the FGLRX driver installed. Also, when I do a search in the dash, I can access the Catalyst control center and play with the driver settings so, as far as I can tell, the driver was, in fact, installed...?

But when I use the Additional Drivers Jockey app, it tells me that the drivers AREN'T installed and 'fails' to install them.

Furthermore, when I look at my System Details, under Graphics, it tells me my machine is using 'VESA: RS880M' which, as far as I can tell, are not the proprietary AMD drivers. So it looks like the drivers are present on my machine but that Ubuntu isn't using them.

Also, I have a copy of Starcraft Brood War that I like to run under Wine on a different computer (a Desktop machine, also Ubuntu 12.04) and it works fine there, but here on my laptop, the framerate is very slow and choppy. So I'm wondering if these issues are related to Ubuntu using the VESA drivers and not the proper AMD drivers.

To summarize:

  • FLGRX drivers for my ATI graphics card seem to be installed, but Jockey and System Details tell me otherwise. Jockey says they are not installed but then fails to install them, and System Details says I am using VESA (which I assume is different and not what I want). I want the propietary drivers because I suppose they will run faster. What is VESA? Is there a better alternative? How is it that apt-cache tells me that the 'fglrx-updates' package is installed, Jockey tells me the contrary, and system details tell me it is using VESA for Graphics?

  • Starcraft (original, 1998 game) has a very choppy framerate but this laptop has a dual-core processor with 4GB of RAM so I'm assuming it has to do with my graphics drivers (lack of 2D/3D acceleration?) Does Starcraft being slow have anything to do with the drivers not being properly installed?

I'm lost. Let me know if I'm not making any sense.


2 Answers 2


I suggest two things

1 In a terminal type the following


This will tell you if fglrx is installed and working well you should see an output similar to:

$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 4300/4500 Series       
OpenGL version string: 3.3.11399 Compatibility Profile Context

If not it has not installed properly and I would follow the advice on the Ubuntu ATI page here Ubuntu ATI site

I usually always install the ATI drivers in the terminal with the following command

sudo apt-get install fglrx fglrx-amdccclete

You may also need to reinstall the updates again:

sudo apt-get install fglrx-updates fglrx-amdcccle-updates

It can be a pain I know from experience. Sometimes I have had to go back the beginning by cleaning out fglrx (sudo apt-get purge fglrx*) and starting afresh.

Let us know how you get on

  • flgrxinfo yields the exact same output you described. So this tells me that flgrx is installed properly. flgrx-updates and fglrx-amdcccle-updates are installed. However, flgrx and fglrx-amdccclete are not. Are you saying I need both?
    – Ouairz
    Commented May 26, 2012 at 21:29
  • I think yes. I alway have to do sudo apt-get install fglrx at the very minimum Commented May 26, 2012 at 21:59
  • 1
    No, you don't need or really want both installed. Regular flgrx is a version that remains the same throughout the life of the ubuntu version, while -updates will get upgraded as new versions of the driver are released, as I understand it. -updates has never worked for me so far in 12.04, you may want to give the regular variant a try and remove the -updates packages. Commented May 26, 2012 at 22:44
  • Ok, thanks. I installed the -updates one, since I figured it was best to have the latest and greatest. It's working fine (for now) but I'll definitely give the regular variant a shot and see if my Starcraft framerate improves...
    – Ouairz
    Commented May 27, 2012 at 4:45
  • 2
    cool. if you have solved this now can you mark it as solved please Commented Jul 6, 2012 at 11:55

You may enter this page: How do I fix my installation of ATI Catalyst Video Driver in 12.04 LTS? or enter this page if necessary: http://wiki.cchtml.com/index.php/Ubuntu_Precise_Installation_Guide You just only change your AMD Catalyst version name which you have downloaded.

First of all, if you have ATi Radeon HD 4xxx and older, you can only use catalyst 13.1 on ubuntu 12.04. If you have Radeon HD 5xxx and newer, you can use the latest catalyst (except Ati Mobility Radeon HD 5650)

  1. Open terminal with pressing Ctrl + Alt + T
  2. Purge AMD driver first:

    $ sudo sh /usr/share/ati/fglrx-uninstall.sh (if file is existing)`

    $ sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*`

    $ sudo rm /etc/X11/xorg.conf`

    $ sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 xserver-xorg-core`

    $ sudo dpkg-reconfigure xserver-xorg`

    $ sudo reboot`

    **If you never installing fglrx/catalyst driver before, command above are not necessary.

    After reboot, open terminal, type:

    $ sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases fakeroot libqtgui4`

  3. Download the driver from AMD Website. Assume it have file name: amd-driver-installer-catalyst-12.10-x86.x86_64.zip

  4. Create new folder in the home directory (assume the folder name is "Catalyst"), so that /home/your login name/Catalyst
  5. Unzip the downloaded driver into Catalyst folder.
  6. Right click the unzipped file and click properties -> Permission -> tick the Execute box, then close it.
  7. Open terminal, with the assume above, type:

    $ cd /home/your login name/Catalyst

    $ sudo sh ./amd-driver-installer-catalyst-12.10-x86.x86_64.run --buildpkg Ubuntu/precise

    $ sudo dpkg -i fglrx*.deb

    $ sudo amdconfig --initial -f`

  8. Restart your computer

    $ sudo reboot`

  9. You have state of the art ubuntu on you computer!

Please report with this method. Maybe this can help you bro.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .