8

I am having this weird problem in Ubuntu 22.04. My laptop gets stuck at the shutdown screen every time I use shutdown and I have to manually press the power button for 5 seconds to turn the machine off.

I've tried this solution. it does not work for me. please help me to solve this issue.

2

4 Answers 4

9

I recently upgraded to Ubuntu 22.04.3 and, both the machines that I upgraded, faced this issue.

For me the issue was fixed on both the machines by installing the Nvidia driver version applicable for the Nvidia graphics card on the machines. This is the same solution that is linked in the question, and mentioned here.

The graphics cards on my machines were GeForce RTX 3050 and GeForce RTX 3050 Ti, so I picked the correct driver version from this site. In essence, the search on the site is just used to identify the correct driver version.

enter image description here

Replacing the Nouveau driver by the Nvidia driver was done by simply installing the Nvidia driver (version 535 in my case). Specifically, I didn't have to explicitly remove the nouveau driver. Just running the command below worked for me.

Note: It's worth mentioning that don't just copy paste and run the command from below, but replace the 535 in the driver version with the driver version applicable for your hardware, the one identified from the search mentioned earlier.

$ sudo apt install nvidia-driver-535

Following a reboot, the machines were restored to their normal shutdown behaviour.

Update

Another point mentioned by Capitoneo in his answer is also relevant. The Additional Drivers section was blank after the upgrade to 22.04. After following the above steps even the additional drivers list got restored.

5
  • 1
    My error message was "ACPI BIOS Error, AE_NOT_FOUND". I upgraded the Nouveau drivers to Nvidia-drivers using your method above. This really worked!
    – pip1726
    Commented Sep 3, 2023 at 6:10
  • when clicking accept and download on nvidia website nothing happens. Did you download the driver from the website or from the command line ? Did you uninstall old drivers first ?
    – Ced
    Commented Dec 8, 2023 at 7:48
  • @Ced - The website is used only to search for the correct driver version that is applicable for our specific hardware. I will clarify it in the answer. The driver itself is installed via the command line as mentioned in the answer. The nouveau driver is still installed on my setup but just not selected as the active one. Commented Dec 8, 2023 at 14:05
  • Just came across this from Facebook. This is the craziest thing! Does anyone have any idea how the graphics driver fixed this issue?
    – Richard
    Commented Mar 6 at 3:10
  • @Richard - I haven't looked into the root cause of this myself yet. I just looked for solutions and reported the steps that worked for me. From the limited understanding that I have, though crazy as it seems, this is still very much plausible. Drivers work closely with the kernel and a glitch somewhere can have seemingly unrelated side effects. Even if proprietary drivers don't go well with the spirit of open source, they still to me seem like the best bet for being most up to date, both bug fix wise and functionally. Commented Mar 6 at 5:22
1

just say my experience (on ubuntu22 today)
//not applicable in all situations

check last poweroff log

after boot, check previous power off syslog.

journalctl -b -1 -r
  • -b -1 //previous boot
  • -r //show log in reverse order
Nov 11 20:10:45 u22 systemd[1]: et.service: Failed with result 'timeout'.
...
Nov 11 20:10:45 u22 systemd[1]: cups-browsed.service: Failed with result 'timeout'.
...
Nov 11 20:09:16 u22 systemd[1731]: Reached target Shutdown. 

It really wait 90 sec timeout..

disable stuck service

mine was 2 service stop timeout,
// 90 seconds force stop as default.

  • et.service
  • cups-browsed

I don't use them, stop & disable it.

sudo systemctl stop et.service
sudo systemctl disable et.service

sudo systemctl stop cups-browsed
sudo systemctl disable cups-browsed

then poweroff succeed in 5 seconds.

ref: https://www.cnblogs.com/apirobot/p/14528996.html

0

I just did sudo apt update and sudo apt upgrade and it fixed the issue for me.

0

For me the issue was resolved by installing the GPU driver , NVIDIA in mycase GEFORCE RTX 3050, which I downloaded from the website https://www.nvidia.in/Download/index.aspx?lang=en-in

  1. Ensure cc is already installed in your system in order to compile the driver sudo apt install build-essential

  2. Before Installing the driver, be ensure that service of xserver must be stopped, use following command

sudo service lightdm stop

  1. goto tty terminal sudo init 3

  2. Enter login and password and then go to folder where the driver is downloaded and execute the following command sudo ./NVIDIA-Linux-x86_64-535.104.05.run

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .