Summary: I am trying to install the Radeon HD 5450 graphics card. When I do, regardless of what drivers are installed/uninstalled I get a blinking monitor- not a black screen or a splash screen, but literally no monitor is detected and so the frontend doesn't even start. I cant ctrl+shift+F1 to a terminal, I can't hold shift during boot to access BIOS. I have tried everything I can think of. Please help!

My system: XPC shuttle Ubuntu 12.04 graphics card (old) GeForce 6200 graphics card (new) Radeon HD 5450 I also have onboard graphics

Background: I am trying to upgrade my graphics card from my old nVidia to a newer Radeon. I started by hoping everything would just work and shutting down the system and popping out the old card and sticking in the new one. No luck- the monitor is not detected. So in order to fidget, I have to reinstall the old card to access a terminal. For some reason I can't just use the VGA port for the onboard graphics with a card installed-If I do the monitor is still not detected. If I pull out the card and try to use the onboard graphics, things get weird and Ubuntu doesnt boot properly, although I can get to the BIOS. Also For some reason I can't get ssh to work properly with other computers on my network but i suspect that is a whole other problem. So I reinstall the old card, and remove the proprietary nVidia drivers I was using. Then I install fglrx for the Radeon card. repeat installation process- still no monitor detected. Put the old card back in and remove fglrx (assuming the drivers weren't compatible or something) and try to install with no additional drivers (I reinstalled xorg.conf from apt as well just to be safe). Still no monitor detected. This is a very frustrating problem because in order to fix anything I have to install/remove components. I have taken out and put in this card like 40 times. I would be tempted to assume this is an Ubuntu problem and just erase and install windows, but the fact that I get no monitor at all (and not just a black screen) suggests that a new operating system won't help since the card should be detected before Ubuntu boots (right?) I am on day three of trying to troubleshoot this problem and I need a fresh set of eyes. What should I do next? Will installing windows help? what about a fresh ubuntu installation? I will try anything at this point. All my files are already backed up, so I don't have anything to lose.

  • I experienced the same thing, Why can not install with live Ubuntu 12.04 from usb/DVD ? if VGA ATI 4350 installed. While installing Windows 7 so easily? My PC specification : Motherboard : HP0a64h Processor : AMD athlon 64 X2 +6400 VGA : - GPU RS482 (Graphic standar) - GPU RV710 ATI RADEON HD4350/ASUS EAH4350 Series Memory : 3 GB Help Us... Cape deh....udah utak utik bios, instal fglrx, gonta ganti driver ati masih gak bisa juga. (bahasa Indonesia) – user268372 Apr 13 '14 at 5:36

I'm new in Linux. But not new PC technician. Ubuntu I use for two months. What I see, that you have not tried the Live UBUNTU from USB (or DVD). See what happens. If you get into Live Ubuntu, then I guess is somehow bad your installation (I would do fresh install). When you will success with Live Ubuntu with new your Radeon GPU open terminal and enter: lspci | grep VGA. you should get something like that:00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) - it depends on GPU that use your system. I recently upgraded the one system from old Radeon X800GTO to the new Radeon HD7750. It was totally good guide in AMD site ('unofficial wiki' I think) - everything works fluently without any issue (gnome desktop have not tried, since I love Unity) even cool Unigine game Oil Rush with old P4 630 goes very great. So your 5450 definitely should work. Fresh install is my choice and suggest.

  • I did try a live CD. I still cannot see anything because the monitor is totally blank, so using a live CD doesn't help me troubleshoot. Also, since I posted my question, I have tried setting GRUB to boot with the nomodeset option enabled, and also set the PCIE to be the primary output in the BIOS. Still nothing. – Graham May 29 '12 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.