Snap keeps telling me to close my apps so it can update, but then promptly doesn't update them. I'm extremely irritated and just want to filter Snap notifications out while other notifications remain so I can work.

There doesn't seem to be an easy way to disable Snap auto updates, so I'm wondering if there's a way to prevent the notification from popping up on XFCE.


  • 1
    I too am looking for an answer to this. I have tried disabling the notification in Settings:Notifications:Apps, but it still appears on my desktop. I am not interested in fiddling with refresh.hold or any of the snap internals. I would like it if it automatically updated, say, when I reboot or when I run apt, or whatever. I wouldn't even mind if it auto-magically updated and told me to restart the browser. But I don't want to see the notification. It is a distraction.
    – uuid
    Aug 23, 2022 at 22:27

2 Answers 2


Update: You cannot do this, since io.snapcraft.SessionAgent sends notifications at high priority, which goes through Do Not Disturb and filters. As much as I dislike being "that comment", your best bet is to not use Snap.

If Snap followed the notification rules, you could disable via io.snapcraft.SessionAgent from being able to send Notifications. You can do that from Settings -> Notifications -> Applications, and toggling io.snapcraft.SessionAgent.

  • Snapd sets the priority based on how much time you have until it force-updates. However, xfce4-notify does not support the "priority" field and only looks at the message timeout. Snapd always sets the timeout at 0, and for some reason xfce4-notify interprets this as a "CRITICAL" message and disregards the filter. Dec 4, 2022 at 1:14
  • The behavior of xfce4-notify is not according to the spec. According to the spec, the timeout should only change how long the message is shown, not the priority of the message. Dec 4, 2022 at 1:28
  • Moreover, the Gnome and KDE notifications settings don't use "urgency" to decide whether to show a notification of a filtered app. It's clear that XFCE is the one not following the rules. Dec 4, 2022 at 1:35

I use Ubuntu 18 and the following command disabled these notifications:

snap set core experimental.refresh-app-awareness=false


  • This only works temporarily, notifications come back
    – Dr-Bracket
    Mar 9 at 14:55
  • That's unfortunate to hear... For me, these notifications have not returned since I used the command many months ago. Maybe more settings are involved to to block these notifications. Unfortunately I'm not experienced enough in Linux to know what they might be. I hope my humble contribution to this thread might help somebody defeat this menace in the future.
    – Andris T
    Mar 9 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.