0

I just installed Ubuntu 22.04 on a Dell Precision 7750 laptop. In the process of transferring software and files, the SD card was producing errors when unmounting and working unreliable. I will describe a behaviour that I've verified it repeats over and over reliably.

At some point the SD card reader just vanished from the system, it didn't showed up as unmounted device, and nothing happened when I inserted cards. When troubleshooting I did a lspci and magically and unexpectedly, the SD card showed up again and mounted automatically. The relevant line of the command output was

6f:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5260 PCI Express Card Reader (rev 01)

Then, if in Nautilus I eject the card, it gets unmounted, but the "eject" icon persists. If I try to mount it again, I get the following error:

Error message 1

If I insert a new card, it is not recognized, and the same error shows up if I try to mount it. To eject the card, I have to go to the Disks Utility, which shows this error

Error message 2

Sometimes the card disappears others, I have to restart the Disks utility for the card to disappear from Nautilus.

At this point, the SD card reader doesn't work at all, nothing happens with new cards, and it doesn't show up as an unmounted device. Just as the start. Then if I run lspci it comes back to life. Although, this only happens if there is a card inserted. If there is no card, running lspci does nothing, and the card reader stays dead.

Any idea of what's going on?

0

You must log in to answer this question.

Browse other questions tagged .