I am getting this error frequently while updating Ubuntu 12.04 LTS. How can I fix it? Log is:

Ign http://archive.scrapy.org precise/main Translation-en
Fetched 6,620 kB in 1min 21s (81.2 kB/s)
W: Failed to fetch http://archive.scrapy.org/ubuntu/dists/precise/Release.gpg
Something wicked happened resolving 'archive.scrapy.org:http' (-5 - No address associated with hostname)
  • I recently encountered this issue on my Pi (running headless - no GUI easily available to configure it) - it turned out that I had mucked up editing the /etc/netowrk/interfaces file (based on this). So others encountering similar issue may want to check their network configuration. – Wilf Jun 30 '15 at 20:40

This has been a long term problem with apt, and Ubuntu has never fixed it. Apt doesn't seem to use the same DNS servers that the internal system does - 'ping ' returns a correct IP address. Apt-get claims that the hostname isn't found.

"Something wicked happened resolving 'extras.ubuntu.com:http" (Which sounds, somewhat, like it's trying to resolve a .com:http domain, which isn't a valid TLD)

To modify /etc/hosts, use the following:

Ping each of the names that are failing to resolve - PING extras.ubuntu.com ( 56(84) bytes of data.

Use your favourite editor, such as vi - 'sudo vi /etc/hosts'.

Scroll down to the end, and add a line such as the following extras.ubuntu.com  (with the appropriate name and IP address. IP is first) 

Save the file, then re-run apt-get. Once you've run apt-get, edit /etc/hosts again, and comment out the line with a hash mark - #. (or delete it entirely)

# extras.ubuntu.com

The reason to comment out/delete the line is that Ubuntu apparently shuffles their servers around randomly, and that might not be the correct IP the next time.


http://archive.scrapy.org/ seems like a perfectly working Ubuntu mirror, so while I'd usually ask you to provide information about what Software Sources are configured, it looks like this problem is either specific to your Ubuntu system, or was a short-lived problem with (or accessing) your DNS server. (The problem is not actually with the server at http://archive.scrapy.org/ itself, though it may have been due to a configuration problem for that server's DNS record.)

This is, of course, assuming that you have Internet access on the affected machine. If you don't, then you need to connect to the Internet before updating. It's quite normal to see errors like that if you don't have Internet access, or if your Internet connection itself is interrupted.

The problem may have gone away by itself. If not, you can try a different DNS server ( and are good public DNS servers operated by Google), and/or try a different mirror for updating Ubuntu.

  • 1
    it's a short-lived problem when I update with apt-get update the error goes away. Will try google dns server. – bernaulli May 28 '12 at 6:28

That hostname resolves to an Amazon EC2 instance. It's possible there was some transient issue which is now solved as it resolves fine here. Does it now work for you?


When I got this error, I put the IP address of the Ubuntu mirror in /etc/hosts. No more error. (When I queried the mirror in DNS there was never a problem or delay in response, so I'm not sure of the root cause of the error.)

  • 2
    I recommend expanding this to explain in detail how to edit /etc/hosts in the way you recommend. – Eliah Kagan Apr 5 '13 at 20:25

I got the "No address associated with hostname" message with Centos 6.5 when I said yes to IPv6 and apparently the ISP DHCP didn't have it. It solved the problem when I commented out the line in /etc/hosts:

# ::1     localhost6.localdomain6  localhost6

protected by Community Oct 15 '14 at 6:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.