31

When I open a terminal using CTRL+ALT+T in Unity, I would like this window to be automatically maximized, rather than to have to additionally hit ALT+SPACE and the 'X' key to make the window that contains it maximized.

If my memory serves me right, I do remember that there used to be a maximize mode that we can set in preferences, but I can't seem to find it now. Any ideas?

13 Answers 13

18

You can use the Compiz Window Rules plugin for this.

  1. Make sure you have the CompizConfig Settings Manager installed Install compizconfig-settings-manager and run it.

  2. Then, enable the Window Rules plugin:

    enable window rules

    and set it so that windows with the class Gnome-terminal are matched:

    enter image description here

If you're using a different terminal, use the + button to build up a match expression for your terminal.

If you'd like your terminal to be fullscreen instead, you can use the appropriate rule in the plugin's config dialog.

In newer versions of Ubuntu (definitely in 16.04) you need to have compiz-plugins installed package to access Window Rules.
If you don't have it you need to install it with sudo apt install compiz-plugins and reboot.

  • Nice! Just what I'm looking for! Thanks! However, do you happen to know the files in which the CompizConfig modifies to achieve this? Maybe I can edit it directly rather than install a whole program just to get one simple task done. :) – Vern May 26 '12 at 19:15
  • 2
    No window rules in latest compiz manager-? – umpirsky Nov 25 '12 at 12:55
  • 3
    You have to install the compiz-plugins package (sudo apt-get install compiz-plugins). – Jacob Jan 1 '13 at 21:10
36

@Bhargav was close to what you need to maximise the window - you just need to use big numbers.

  • Open a Terminal
  • Select Profile Preferences from the Edit Menu.
  • Tick Use custom default terminal size and enter a default size that is too large for the screen e.g. 240 columns and 100 rows.
  • Click close then open a new Terminal by clicking the icon OR pressing Ctrl + Alt + T

The new terminal window should be maximised.

Can I add that your question is a bit vague, the title asks for full screen (I take that as fills the entire screen, with no panels or unity bar visible) but the actual question asks how it can be automatically maximised (fill the desktop space leaving panels and unity bar visible) which are two different request in my book.

Based upon advice I was given here: How to make terminal start maximized?

  • 2
    That's the easiest way to do it IMHO. no playing around with Compiz, no having to create a new application shortcut, etc. – Nikola Ivanov Nikolov Jul 10 '14 at 11:15
  • but this solution does not work as of Ubuntu 15.10 – user907860 Nov 16 '15 at 15:58
  • Works great in 16.10 @user907860 – Teedeez Mar 6 '18 at 7:31
  • this solution makes it maximal-sized, but still not maximized. on certain installations and desktop managers, the two are not the same. maximal-sizing will still leave a default thin strip around a window to make it appear that the window is floating. maximized is when the window in question is the only window you can possibly focus on unless you open a different window – Aalok Dec 16 '18 at 4:44
20

While the user has an accepted answer using Compiz, I dislike Compiz, personally and wanted a "cleaner" way.

If you create a file at ~/.local/share/applications/gnome-terminal-fullscreen.desktop.

Use a text editor and put this in it:

#!/usr/bin/env xdg-open

[Desktop Entry]
Name=Terminal Fullscreen
Comment=Use the command line in fullscreen
Exec=/usr/bin/gnome-terminal --window --full-screen
Icon=utilities-terminal
Type=Application
X-GNOME-DocPath=gnome-terminal/index.html
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=gnome-terminal
X-GNOME-Bugzilla-Component=BugBuddyBugs
X-GNOME-Bugzilla-Version=3.4.1.1
Categories=GNOME;GTK;Utility;TerminalEmulator;
StartupNotify=true
OnlyShowIn=GNOME;Unity;
Keywords=Run;
Actions=New
X-Ubuntu-Gettext-Domain=gnome-terminal

[Desktop Action New]
Name=New Terminal Fullscreen
Exec=/usr/bin/gnome-terminal --window --full-screen
OnlyShowIn=Unity

This puts an application in your Activities search results call Terminal Fullscreen. All it is doing is calling the same gnome-terminal command but with the --window --full-screen arguments, so it launches in full screen. If you always want it fullscreen, just always use that.

Hope this simplifies things for someone.

  • 3
    The full-screen here overrides the status bar. It is not the same effect as maximising window size when opened... – Augustin Riedinger Nov 26 '13 at 10:34
  • 5
    I would use --maximize option. See gnome-terminal --help-window-options. – Grzegorz Żur Jan 28 '15 at 14:16
5

Go to System Settings -> Keyboard. Under the "Shortcuts" tab, go to "Custom Shortcuts". Create a new entry named "Launch Terminal Fullscreen" (or whatever), and enter the following as the command:

gnome-terminal --window --full-screen

You're supposed to be able to click on that entry and then press the key combination you wish to use in order to set the new keyboard shortcut, but for some reason, that wasn't working for me. If that's the case, you might need to edit the launcher shortcuts manually...

According to this page, the keyboard shortcuts for Unity can be found at:

~/.gconf/desktop/gnome/keybindings

Each keybinding seems to be in a separate folder, named "custom0", "custom1", etc. Edit the "%gconf.xml" file found in one of these folders which contains the keyboard shortcut definition you just added in the "Settings -> Keyboard" dialog, (if you added one). Here's mine, mapped to "CTRL-ALT-m":

<?xml version="1.0"?>
<gconf>
<entry name="action" mtime="1381112788" type="string">
    <stringvalue>gnome-terminal --window --full-screen</stringvalue>
</entry>
<entry name="name" mtime="1381112788" type="string">
    <stringvalue>Launch Terminal Fullscreen</stringvalue>
</entry>
<entry name="binding" mtime="1381110910" type="string">
    <stringvalue>&lt;Primary&gt;&lt;Alt&gt;m</stringvalue>
</entry>
</gconf>

I suppose you could try just copying the above into a new file named "%gconf.xml", and putting it in a new folder named "customX", (where "X" is the next available number), in the ~/.gconf/desktop/gnome/keybindingsfolder. I haven't tried this, yet.

After editing the XML by hand, I logged off and logged back in in order to force a re-scan of the keybindings, and voila!

5

I realise this is old now but thought other people might be having the same trouble.

This worked for me. Open a terminal and type:

    sudo gnome-desktop-item-edit /usr/share/applications/gnome-terminal.desktop

Then put:

    --maximize

in the 'Command:' box, after 'gnome-terminal'

You might need to adjust your keyboard shortcuts. Can't remember as mine are all custom anyway.

  • 2
    This is the best solution. Ubuntu 15.04 does not have gnome-desktop-item-edit, so replace that with vi instead. Then go to the line that says Exec=gnome-terminal and change it to Exec=gnome-terminal --maximize. Also, go to Keyboard in System Settings, and remove the shortcut for the normal terminal, add a custom shortcut with the command gnome-terminal --maximize. Be aware, this changes it for all users. – texasflood Jun 13 '15 at 16:38
  • The above comment should be the accepted answer. – Dan Nissenbaum Jul 16 '17 at 19:43
  • Same goes for mate-terminal --maximize – JaR Feb 25 at 12:15
4

If you want a truly full-screen terminal, press CTRL-ALT-F#, where # can be 1-6 (I.E. CTRL-ALT-F1). To return to Ubuntu, press CTRL-ALT-F7.

  • That's just using the terminal. What I'm referring to is inside Unity and having the terminal come up in a window in Unity :) – Vern May 26 '12 at 19:11
  • This may not be the correct answer for the question. But, helped me to get out of the terminal that I accidentally opened by hitting CTRL - ALT - F1. – mbhargav294 Oct 4 at 21:25
2

Goto system settings->keyboard->shortcuts

Pressing CTRL+ALT+T in Ubuntu will open the gnome terminal window as a regular floating window. Follow this quick tutorial to have this window started maximized or fullscreen by default. Remove Default Launcher

Find the keyboard settings and under the Launchers category for Shortcuts change the Launch terminal from CTRL+ALT+T to something else. I changed mine to CTRL+ALT+W just so I can easily use the original windowed version.

Add a new custom shortcut entry and call it “Launch Terminal Fullscreen” and enter the following as the command.

gnome-terminal --window --maximize

Assign The Shortcut

New custom shortcuts for keyboards are disabled by default. You need to assign the CTRL+ALT+T keyboard code for the new shortcut to work.

You should be all set now. Give it a try.

Note: try both --fullscreen and --maximize see this link for more information

2

My solution is override the default key binding for Run terminal

  1. Go to System > Preferences > Hardware > Keyboard Shortcuts

    (I'm using ubuntu mate, it might be different in other systems, the point is you get to the Keyboard shortcuts Window)

  2. Add a custom shortcut by clicking the + button. Fill in 2 input fields

    Name: What ever you want (Eg: Terminal maximized)

    Command: mate-terminal --maximize as you are using mate terminal

    or gnome-terminal --maximize as you are using gnome-terminal

    Then you add shortcut as Ctrl + Alt + T

    Since then, when you hit Ctrl + Alt + T, you will get a maximized terminal window.

1

U can try an alternative approach to that of maximize.

Open Terminal -> Edit -> Profile Preferences, In the General Tab, Check the

"Use Custom Default Terminal Size"

box and play around with those values (Rows and Columns).

U can set it to any size you'd wish to.

  • I've tried using that, but even with 80 x 24 on my screen leaves a border that full maximize of the window doesn't :) – Vern May 26 '12 at 19:11
0
  1. Go to System Settings->Keyboard->Shortcuts tab.
  2. Select "Custom Shortcuts" from the sidebar and add a new shortcut.
  3. For the name give something like "Full screen Terminal" and in the field textfield insert the command

    /usr/bin/gnome-terminal --window --full-screen
    
  4. Now select the shortcut keys of your choice by clicking the disabled field against the full screen terminal shortcut you created and press the accelerator keys. Like I chose Ctrl+Shift+T

  5. It's done. Now you can close everything and try the new shortcut you created.
0

Lateral thinking answer: use guake:

sudo apt-get install guake

When you hit F12, it opens a fullscreen terminal for you.

0

you can set initial terminal size on Edit - Profile Preferences. to make full screen set column and rows size to 256. I'm not recommending to use third party tools for such situation :)

-1

Drag the title bar of the application to top of window.

  • 2
    That makes an already-running Terminal take up the whole screen. This question is asking how to set things up so that the Terminal takes up the whole screen automatically, whenever it is launched. – Eliah Kagan Jun 13 '12 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.