5

I am using Ubuntu 22.04.1 LTS desktop. I want to share the ethernet connection via wifi hotspot on my laptop. After turning on the hotspot, I am not able to connect any device from the hotspot, it shows that the network is saved.

I tried setting the security of the hotspot to none using nm-connection-editor, but it hasn't worked. I changed the password using network manager but still when I turn on the hotspot, it asks to enter the password, or else it generates the password on its own (It automatically changes the setting in the network manager when I turn on the hotspot i.e. it automatically resets the setting in network manager). In the mobile it shows a plus sign over the lock in wifi (a have attached the screenshot of it). Please give me a solution.

I am attaching the screenshot of hotspot in my laptop and from mobile.enter image description here

enter image description here

5
  • Does the hotspot show up on devices you are trying to connect or not at all? Please expand your question to explain exactly where things go wrong.
    – zwets
    Commented Aug 20, 2022 at 19:57
  • I have expanded my question @zwets Commented Aug 22, 2022 at 3:38
  • Since there is no question mark in your question, I just want to make the question absolutely clear: You are only asking how to make a hotspot without a password. Hotspots with passwords already work for you, right?
    – Natan
    Commented Aug 27, 2022 at 8:59
  • 1
    no, I am not able to connect via hotspot with WPA and WPA2 personal security. the device won't connect even if I give the correct password or scan the QR code. when I turn the security to none and then turn on hotspot, then still the settings in network manager are automatically changed to WPA and WPA2 personal security. @Natan Commented Aug 27, 2022 at 13:19
  • 1
    You could try to follow: anooppoommen.medium.com/… to see what step fails. It also explains how you can check whether your wireless card supports being an AP. But I think os would notice that on its own.
    – Natan
    Commented Aug 27, 2022 at 13:27

10 Answers 10

8

What got things working for me was the disablement of Protected Management Frames

nmcli c modify Hotspot 802-11-wireless-security.pmf 1
2
  • 1
    Thanks, it worked for me too. Commented Mar 23, 2023 at 5:46
  • Thank you. worked! clarification # nmcli c modify <Your_Hotspot_Name> 802-11-wireless-security.pmf disable
    – rajesh
    Commented May 31 at 8:29
7

This seems to be an issue with wpa_supplicant version 2.10+ ([1], [2]). You can either use hostapd to create a software AP manually by first masking NetworkManager for the Wifi device [3] and then following the instructions linked in the same article---or try using a different security protocol such as WPA3/SAE. The latter can be achieved using:

nmcli connection down Hotspot
nmcli connection modify Hotspot 802-11-wireless-security.key-mgmt sae
nmcli connection up Hotspot

Take care not to use the GUI to activate the hotspot as this will reset the settings.

Switching to WPA3 solved the problem in my case and works as long as your client devices support this protocol.

1
  • This worked for me, after the Linux mint 21 version update hotspot with the password suddenly stopped working. Thank you!!! Commented Mar 27, 2023 at 4:16
2

This looks like the bug raised for Ubuntu 20.04 - Can't connect to hotspot created on ubuntu

Posting this as an answer as I don't have enough reputation for comment.

1

Do this using the network-manager

Install it first if you don't have it :

sudo apt-get install network-manager

Then

  1. Search for network manager in your Desktop environment,
  2. Create a new connection, select wifi.
  3. In the WIFI tab go to Mode and change it to Hotspot.
  4. Choose your network interface e.g wlo1 in the device option,
  5. Then go to IPv4 choose Shared to other.. in the Method option,
  6. Add normal security WPA/WPA2 Personal with simple password
3
  • This didn't worked. Commented Aug 21, 2022 at 4:06
  • @sawankt The plus sign on your wifi SSID is for an android feature called Wifi calling You can disable that from the settings, depending on your android version,try to disable that feature, delete the network profile in your phone and reconnect to Ubuntu. Wifi calling is way to make calls using WAN using the internet communication and not normal antennas.
    – user1619729
    Commented Aug 21, 2022 at 15:03
  • I have disabled the wifi calling, but still it dosen't work. Commented Aug 22, 2022 at 3:41
1

You can try using different Wi-Fi security protocols to see if any of them work. Also check if you can connect your Ubuntu box to a mobile hotspot via Wi-Fi, if not, try via USB cable. Chances are it's a broader Linux issue. Linux often has problems with proprietary drivers as a result of the proprietary business practices of the industry. My box, nor laptop, running the same version of up-to-date Ubuntu cannot connect to mobile hotspot nor WPA & WPA2 Enterprise networks. It can only connect to the mobile hotspot when using a USB cable. It can see the wifi network just fine but when trying to connect, it starts looping the password prompt window. It's an indication that Linux is unable to get the correct settings from the router. I have none of these issues on Windows side. You should really ask this question at the Linux kernel dev forums. Ubuntu is a reliable distro using standard kernel drivers and network tools so I doubt this is a Ubuntu-only issue.

1

I have the same issue on Ubuntu 23.10 with KDE. The hotspot works well if I set no password and I could not connect as long as I set any password.

I see the solution in a good reference https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/issues/104

So, basically what you need to do is to create a hotspot connection first, and name it, for example, ad myhotspot and set the password in the GUI. Then you can turn it off by

nmcli connection down myhotspot

and then config it by

nmcli connection modify myhotspot wifi-sec.pmf disable

and then turn it on again

nmcli connection up myhotspot

Hope this helps.

0
  • Open the system menu from the right side of the top bar.

System Menu

  • Select Wi-Fi Not Connected or the name of the wireless network to which you are already connected. The Wi-Fi section of the menu will expand.
  • Click Wi-Fi Settings.
  • Press the menu button in the window's top-right corner and select Turn On Wi-Fi Hotspot….

Note: If you are already connected to a wireless network, you will be asked if you want to disconnect from that network. A single wireless adapter can connect to or create only one network at a time. Click Turn On to confirm.

You can also connect to the wireless network by scanning the QR Code on your phone or tablet using the built-in camera app or a QR code scanner.
1
  • This dosen't answer my question Commented Aug 25, 2022 at 1:36
0

When I open GNOME settings to the WiFi page, the "create hotspot" option is initially greyed out. Switching to any other settings page and coming straight back makes the option available. Similarly, if I first open GNOME Settings to a different page (ie. bluetooth from the shell top right menu), and thereafter navigate to the WiFi pane, then the option is available. Steps to reproduce:

Solution:

  1. Open GNOME Settings
  2. Try to activate hotspot, it is greyed out
  3. Switch to "Network" or "Bluetooth" or "Background" setting page
  4. Back to WiFi "Activate hotpot" menu option is available
0

use this command in cmd sudo ufw disable and after this your work is done you can again enable this by using sudo ufw enable

1
0

This is the most accurate code that can solve your problem

`

  1. nmcli connection down Hotspot
  2. nmcli connection modify Hotspot wifi-sec.pmf disable
  3. nmcli connection up Hotspot

`

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Mar 22 at 8:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .