6

I recently upgraded to Ubuntu 22.04 (from 20.04) and now my Mendeley Reference Manager AppImage won't start. I made the AppImage executable and confirmed that libfuse2 is installed. When I try to run the AppImage file from the terminal, I get the following error:

(node:10810) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:10810) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
[10810:0820/002523.646076:FATAL:gpu_data_manager_impl_private.cc(445)] GPU process isn't usable. Goodbye.
Trace/breakpoint trap (core dumped)

Can anyone help with this? Here's a link to the AppImage download in case you are interested: https://www.mendeley.com/download-reference-manager/linux

5
  • I had the same issue on my laptop. It got resolved after I switched to intel graphics instead of nvidia.
    – Roni Saiba
    Aug 20, 2022 at 5:13
  • You can also change your nvida driver to the recommended version. For me driver version 515 caused problems but version 510 is working.
    – Roni Saiba
    Aug 20, 2022 at 5:20
  • @RoniSaiba: Thanks for the suggestion. I'm not ready to give up on my nvidia graphics card just yet (I have a GeForce GTX 1660). I did try your suggestion about changing drivers, but unfortunately the error persists. Aug 20, 2022 at 9:56
  • Similar issue: [27169:0907/120828.102548:FATAL:gpu_data_manager_impl_private.cc(445)] GPU process isn't usable. Goodbye. Trying to change drivers gives an error dialog box with no text and just the error icon and "ok" button. @RoniSaiba, how did you switch which card to use? I too have both an Intel and NVIDIA card. Sep 7, 2022 at 19:17
  • @JakeStevens-Haas I use nvidia-optimus to switch between cards.
    – Roni Saiba
    Sep 21, 2022 at 4:58

2 Answers 2

7

Same error message for me (Ubuntu 22.04). Launching the AppImage gives the following error:

./mendeley-reference-manager-2.77.0-x86_64.AppImage  
(node:21581) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed. 
(node:21581) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
[21581:0908/111909.638885:FATAL:gpu_data_manager_impl_private.cc(445)] GPU process isn't usable. Goodbye.

The solution is to launch the AppImage with the following command line arguments:

./mendeley-reference-manager-2.77.0-x86_64.AppImage --disable-gpu-sandbox

Solution found here: https://forums.balena.io/t/strange-error-message-gpu-process-isnt-useable/357119/2

1
1

I also experienced the same issue on Ubuntu 22.04. I also have a Nvidia GPU card. Changing the driver (to 510) did not solve my issue. I found this solution (install Mendeley via flatpak) that worked (be sure to completely remove the previous version of Mendeley!):

$ sudo flatpak install flathub com.elsevier.MendeleyDesktop 
$ flatpak run com.elsevier.MendeleyDesktop 
2
  • 1
    Great suggestion. I will definitely consider this if I decide to revert back to Mendeley Desktop (from Mendeley Reference Manager). Since Desktop is EOL, it seems that a solution for Reference Manager is needed. Sep 6, 2022 at 5:06
  • 1
    This is not really an answer though. The command installs Mendeley Desktop, which is NOT the same as Mendeley Reference Manager. It is a previous and now deprecated Mendeley client.
    – Neinstein
    Jan 10, 2023 at 14:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .