0

I mean to connect from Win10 to a remote server with Ubuntu 22.04LTS and Gnome desktop, via VNC. I followed the links below. I did all the setup remotely, in a terminal connected via ssh.

  1. Installed (with apt-offline, since the server is behind a proxy) tigervnc-standalone-server, tigervnc-common, tigervnc-tools.
  2. Executed vncserver, and entered the password. Display :1 was taken, it used :2.
  3. Killed the vnc server with vncserver -kill myserver:2.
  4. Created/edited with nano ~/.vnc/xstartup, with the following contents (using gnome right away)
    #!/bin/sh
    # Start up the standard system desktop
    unset SESSION_MANAGER
    unset DBUS_SESSION_BUS_ADDRESS

    #/usr/bin/startxfce4
    /usr/bin/gnome-session

    [ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
    [ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
    x-window-manager &
  1. Changed permissions with chmod +x ~/.vnc/xstartup.
  2. Added user with sudo nano /etc/tigervnc/vncserver.users, adding :2=user1
  3. Started service with sudo systemctl start tigervncserver@:2.service.
  4. Added symlink with sudo systemctl enable tigervncserver@:2.service. This created symlink /etc/systemd/system/multi-user.target.wants/tigervncserver@:2.service -> /lib/systemd/system/[email protected]. Even if I later don't use the service, I note the linked file has a different contents from what is typically quoted:
    [Unit]
    Description=Remote desktop service (VNC)
    After=network.target

    [Service]
    Type=forking
    ExecStart=/usr/libexec/tigervncsession-start %i
    PIDFile=/run/tigervncsession-%i.pid
    SELinuxContext=system_u:system_r:vnc_session_t:s0

    [Install]
    WantedBy=multi-user.target
  1. Killed service with vncserver -kill myserver:2.
  2. Launched the server with
    $ vncserver -localhost no :2

    New Xtigervnc server 'myserver:2 (user1)' on port 5902 for display :2.
    Use xtigervncviewer -SecurityTypes VncAuth,TLSVnc -passwd /home/user1/.vnc/passwd myserver:2 to connect to the VNC server.
  1. Verified the service was inactive with sudo systemctl status tigervncserver@:2.service.
  2. Established an ssh tunnel to port 5902 (as per output above) with ssh -L 59000:localhost:5902 -C -N -l user1 <server IP>
  3. Launched TigerVNC client in Win10, connecting to localhost:59000. I entered the password I setup in step 2 above. I got the login screen.

The problem is that at the login screen I cannot type my password. When I click on the password field, the pointer changes to a cursor, but nothing happens when I type. I guess this means all the rest is mostly OK, even if not 100%.

enter image description here

How can I solve this?


Links I followed

  1. https://www.howtoforge.com/how-to-install-vnc-server-ubuntu-22-04/
  2. https://bytexd.com/how-to-install-configure-vnc-server-on-ubuntu/
  3. https://serverspace.io/support/help/vnc-connection-ssh-tunnel-ubuntu-20-04/

Related

  1. https://superuser.com/questions/1717705/tigervnc-server-not-working-within-systemctl-but-works-fine-separately

Note: I am currently using xRDP. I am at the console only once in about a month or two. This works well, but it has a couple of undesired features:

  1. Whatever I do in my client, it belongs to the client's session. I do not see that in the console.
  2. The few times I tried, the console got laggy, and finally it hung. To use it I had to reboot it. I found no way of releasing my remote xRDP session and start using the console. This is worth another question.

1 Answer 1

2

I think this is caused by the same user being logged in multiple places. Is the user also signed in on the server? I had an issue where trying to sign in with the same setup (tiger VNC on 22.04) the password box was triggered over and over, so you could never sign in. The solution was to sign out of the graphical environment on the server then the VNC session worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .