Using Xubuntu 12.

I can't open either the Software Center or Update Manager. I'm a complete novice!

I get the following error:

Failed to execute command "/usr/bin/software-center %u".
Failed to execute child process "/usr/bin/software-center" (No such file or directory)

I tried all I can think of by update via Synaptic package Manager but nothing I've done works.

I've the CD but now I'm used to this and I don't want to do a clean install and lose all my files etc.

Can a repair be done? or can it be repaired with the CD?

I'm not that good with computers but absolutely love Xubuntu?

Please make my day and tell me it can be solved!

Edit: Some outputs which may help.

alan@alan-Aspire-2930:~$ cd /usr/share/software-center/; ls | grep ^software-center$ 

it means there is software-center and is not deleted.

alan@alan-Aspire-2930:/usr/share/software-center$ sudo ln -s '/usr/share/software-center/software-center' '/usr/bin'
[sudo] password for alan: 
ln: failed to create symbolic link `/usr/bin/software-center': File exists 

it means symbolic link also exists. It is very strange because when you run software-center it says (No such file or directory) !!!


1 Answer 1


cd /usr/share/software-center/

ls | grep ^software-center$ does this yield any output? if yes then only the symbolic link is deleted from /usr/bin/.

to create symbolic link again,

sudo ln -s '/usr/share/software-center/software-center' '/usr/bin' 

if this doesn't help

try reinstalling sofware-center. It seems like python script of software center has been deleted or moved.

edit >

try sudo apt-get install software-center


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.