0

👋

after updating to 22.04 from 20.04 I had no sound at all. After unmuting "Front" in alsamixer I can hear sound as I'm used to. However after shutting down and rebooting settings are back to default.

OS: Ubuntu 22.04.1 LTS

Device: HDA ATI SB

Chip: Realtek ALC892

I tried different stuff, for example as stated here: Howto save AlsaMixer settings?

sudo alsactl store

and also

alsactl --file ~/.config/asound.state store

followed by

alsactl --file ~/.config/asound.state restore

Also tried this https://dev.to/luisabianca/fix-alsactl-store-that-does-not-save-alsamixer-settings-130i which got me close to a solution, however I need to start the terminal in every session to restore alsamixer settings.

I also found out, pulseaudio is actually overriding alsamixer settings since pulseaudio -k resets alsamixer settings even if I changed them manually before.

Any ideas on how to solve my problem?

Any help is appreciated! 🙏🏽

2
  • Change the permissions to read? No idea if that is allowed but you can always revert that ;)
    – Rinzwind
    Commented Aug 16, 2022 at 20:00
  • Tried that by changing rights of /var/lib/asound.state through sudo chmod u=r,g=r,o=r asound.state. Still calling pulseaudio -k overrides the settings I just set before.
    – Neutron7
    Commented Aug 17, 2022 at 21:48

0

You must log in to answer this question.

Browse other questions tagged .