5

Bougth a bluetooth dongle (TP-LINK UB500) and the system is unable to run bluetooth. I have dualbooth with windows 10 and on windows system the dongle works fine.

The issue: The dongle is connected succesfully, but in the settings window it says:

No bluetooth found

Plug in a dongle to use bluetooth

enter image description here

More details:

lusb

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 0bda:0411 Realtek Semiconductor Corp. USB3.2 Hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 003: ID 0b05:1939 ASUSTek Computer, Inc. AURA LED Controller
Bus 001 Device 007: ID 20d6:2016  
Bus 001 Device 006: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 004: ID 2357:0604 TP-Link 
Bus 001 Device 002: ID 0bda:5411 Realtek Semiconductor Corp. USB2.1 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
     Active: inactive (dead)
       Docs: man:bluetoothd(8)

rugp. 15 21:04:13 devpc systemd[1]: Condition check resulted in Bluetooth service being skipped.
rugp. 15 19:07:49 devpc systemd[1]: Condition check resulted in Bluetooth service being skipped.

The system says that the btusb module is not installed

modprobe btusb
modprobe: FATAL: Module btusb not found in directory /lib/modules/5.15.0-46-generic

But when trying to locate it, it returns:

locate btusb
/home/viktoras/linux-5.15/Documentation/devicetree/bindings/net/btusb.txt
/home/viktoras/linux-5.15/drivers/bluetooth/.btusb.c.swp
/home/viktoras/linux-5.15/drivers/bluetooth/.btusb.ko.cmd
/home/viktoras/linux-5.15/drivers/bluetooth/.btusb.mod.cmd
/home/viktoras/linux-5.15/drivers/bluetooth/.btusb.mod.o.cmd
/home/viktoras/linux-5.15/drivers/bluetooth/.btusb.o.cmd
/home/viktoras/linux-5.15/drivers/bluetooth/btusb.c
/home/viktoras/linux-5.15/drivers/bluetooth/btusb.ko
/home/viktoras/linux-5.15/drivers/bluetooth/btusb.mod
/home/viktoras/linux-5.15/drivers/bluetooth/btusb.mod.c
/home/viktoras/linux-5.15/drivers/bluetooth/btusb.mod.o
/home/viktoras/linux-5.15/drivers/bluetooth/btusb.o
/usr/lib/modules/5.15.0-43-generic/kernel/drivers/bluetooth/btusb.ko
/usr/lib/modules/5.15.0-46-generic/kernel/drivers/bluetooth/btusb.ko
/usr/lib/modules/5.15.0-46-generic/kernel/drivers/bluetooth/btusb.ko.bak
/usr/lib/modules/5.15.0-46-generic/kernel/drivers/bluetooth/btusb_bak
/usr/lib/modules/5.15.0-46-generic/kernel/drivers/bluetooth/rtk_btusb.ko

Could please someone help me out with this issue? Any suggestions?

I have read and tried these solutions, but still no luck: Resource#1, Resource#2, Resource#3, Resource#4 and many more

1
  • Note: There is no Ubuntu 20.4 -do not drop the 0
    – Hannu
    Commented Aug 16, 2022 at 17:29

4 Answers 4

13

I was able to connect my UB500 on Ubuntu 20.04.

After running sudo dmesg | grep -i bluetooth I noticed the following firmware file was missing:

Bluetooth RTL: firmware file rtl_bt/rtl8761bu_fw.bin not found 

My solution:

Copy the rtl8761b_fw firmware:

cp /usr/lib/firmware/rtl_bt/rtl8761b_fw.bin /usr/lib/firmware/rtl_bt/rtl8761bu_fw.bin
cp /usr/lib/firmware/rtl_bt/rtl8761b_config.bin /usr/lib/firmware/rtl_bt/rtl8761bu_config.bin

Run modprobe:

sudo modprobe btusb

Restart the bluetooth service:

sudo systemctl restart bluetooth.service

Then re-plug the bluetooth dongle.

0

In my case I found the solution in this forum.

https://medium.com/nerd-for-tech/how-to-install-unsupported-bluetooth-5-0-dongle-on-linux-4bf34aa99fed

the only difference was the name of the file to rename:

rtl8761bu_fw.bin, rtl8761bu_config.bin
sudo cp rtl8761b_config /usr/lib/firmware/rtl_bt/rtl8761bu_config.bin
sudo cp rtl8761b_fw /usr/lib/firmware/rtl_bt/rtl8761bu_fw.bin
1
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review
    – zx485
    Commented Jul 8, 2023 at 17:20
0

I was looking around to see if th TP-Link Ubuntu TP-Link UB500 works on Ubuntu. I have bought one to test it myself, and can say it works out of the box on Ubuntu 22.04 for me.

0

I didn't had bluetooth installed on my desktop machine.

I followed below steps and finally bluetooth is working fine:

sudo apt install bluetooth
sudo modprobe btusb
sudo systemctl restart bluetooth.service

After service restart, do un-plug and re-plug the bluetooth adapter (TP-LINK UB500)

Note:

I am using Ubuntu 23.10 and Kernel Linux 6.5.0-10-generic #10-Ubuntu

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .