11

I am trying to connect a bluetooth speaker to a near fresh install of ubuntu 22.04. I'm having several issues with this.

To try and resolve this I have moved from using the GUI to bluetoothctl.

The steps I am taking to connect to the device are as follows

power on
agent on
scan on
trust #deviceaddress
pair #deviceaddress
connect

here is the system status

bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
     Active: active (running) since Fri 2022-08-12 20:52:25 IST; 15min ago
       Docs: man:bluetoothd(8)
   Main PID: 13854 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 19052)
     Memory: 836.0K
        CPU: 75ms
     CGroup: /system.slice/bluetooth.service
             `-13854 /usr/lib/bluetooth/bluetoothd

when I run pair for device address bluetoothctl registers the device as connected, but the bluetooth device itself doesnt recognise a connection (its supposed to beep). Shortly afterwards I get the authentication timeout error and the device does not get paired.

I don't know why this is, sometimes the connection works when I use the GUI, however this is inconsistent and requires multiple attempts with an indefinite length of time passing after booting into ubuntu before working.

Here is the terminal output with the bluetoothctl info for the device

[Majority Snowdon II]# info 41:42:00:CA:56:64
Device 41:42:00:CA:56:64 (public)
    Name: Majority Snowdon II
    Alias: Majority Snowdon II
    Class: 0x00240418
    Icon: audio-headphones
    Paired: no
    Trusted: yes
    Blocked: no
    Connected: yes
    LegacyPairing: yes
Failed to pair: org.bluez.Error.AuthenticationTimeout
[CHG] Device 41:42:00:CA:56:64 Connected: no

I have followed the advice given here but this has not been successful. This is the only mention of this error I can see online.

I have uninstalled, purged, reinstalled bluez. I have tried using blueman which asks for a pin for pairing, using the pin from the manual here the same error is returned. A final error is shown by blueman discussed below.

Any help on this is much appreciated. As an additional the connect command gives the following error in which I can find very little information about.

[bluetooth]# connect 41:42:00:CA:56:64
Attempting to connect to 41:42:00:CA:56:64
[CHG] Device 41:42:00:CA:56:64 Connected: yes
[CHG] Device 41:42:00:CA:56:64 UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[CHG] Device 41:42:00:CA:56:64 UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device 41:42:00:CA:56:64 UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device 41:42:00:CA:56:64 ServicesResolved: yes
Failed to connect: org.bluez.Error.Failed br-connection-unknown
[CHG] Device 41:42:00:CA:56:64 ServicesResolved: no
[CHG] Device 41:42:00:CA:56:64 Connected: no

I have used hciconfig to enable simple pairing mode, and now I am getting a simple authentication failed error. I've had a look for solutions but cannot find any that are applicable to this.

Today after booting up the computer I was able to pair the speaker, I have no idea why. However I am now getting the error connection profile unavailable. Will keep digging.

I'm back to getting authentication timeout error :(

to try and get any audio coming from ubuntu, I ran an audio jack all the way across the room to the computer, only to find that the only output that now exists is 'dummy output' this is a known issue with intel cpu's but I am running AMD... There is nothing I can find online about this. I really don't know where to go from here. I just want audio from a fresh linux install... Over the last 4 days I've spent more time trying to get this working than I've spent at my job. I'd appreciate any help!

I've been able to get the hdmi ports to be picked up, but the audio jack is nowhere to be found :(

I gave up and did a fresh install again. Through a series of using backups after each change, experimenting with order of installations of my most used softwares... reverting when it failed or dpkg locked up during an update etc... I have got it working.

I couldnt find a direct fix for the bluetooth errors I had, but I spent less time doing the above than I did trying to fix the specific bluetooth issue.

2
  • I'm on Debian sid (Ubuntu is based on Debian sid) and I have almost the same problem, except in my case the error is Failed to connect: org.bluez.Error.Failed br-connection-unknown which does not mention authentication issues, and it comes after "connect" command. My bluetooth device is a loudspeaker (Rockbox Chunk) Commented Aug 17, 2022 at 6:39
  • I had this error also. I honestly couldn't find a fix. I found that doing a complete reinstall fixed it, I had to to this a couple of times before I got everything basic working, but once I did I made a backup using timeshift
    – Andy
    Commented Aug 19, 2022 at 19:01

2 Answers 2

19

I had same problem. I followed next steps to connect my device:

-scan on
-remove XX:XX:XX:XX:XX:XX, if it had already been paired
-trust XX:XX:XX:XX:XX:XX
-pair XX:XX:XX:XX:XX:XX
-connect XX:XX:XX:XX:XX:XX

3
  • Hi, this is generally the recommended procedure as found on several posts on bluetooth connectivity issues. It is in following these steps that the issue became evident. It is unfortunately not the solution to the issue that I had. Thank you for your input though.
    – Andy
    Commented Sep 19, 2022 at 22:29
  • it solved the problem thanks (: Commented Nov 23, 2022 at 0:35
  • it works only from bluetoothctl in terminal, strange ? Commented Jul 9, 2023 at 22:16
1

For anyone else having this problem, I was able to find the solution here! for whatever reason when you uninstall or reinstall pulseaudio or alsa it seems to delete the a2dp module.

a2dp-sink profile connect failed

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .