3

I have to disconnect and connect my bluetooth earbuds after sleep/closing lid (when I change classes ). Why is that and how can I change this behaviour? I use Kubuntu 20.04.4 on a HP Envy 17CE1000n. Earbuds are recognized as J97 (mark and model I don't know, got them as a gift without a box).

2
  • 2
    The behavior is "normal" considering the technologies being used. Everything but the RAM is powered off when sleeping. And after waking up the Bluetooth may or may not automatically reconnect, it usually doesn't. It also depends on the other devices, of course. There is no "fix". Aug 9 at 15:12
  • That makes sense. I'll try the non suspend like @Rinzwind suggested a try. Aug 9 at 15:57

1 Answer 1

5

This is normal: the idea is ... when you suspend you do not use your machine and everything that needs power needs to either stop receiving it or receive an absolute minimum. Basically it is only watching for a "wake on" event: wake-on-keyboard, wake-on-lan.

If you install "Tweaks" you get a couple more options.

  • General -> Suspend when laptop lid is closed -> off
  • Startup applications -> ignore-lid-switch-tweak. This is a script added to the system by "Tweaks".

and wifi, bluetook will stay active on lid close. You do stop using suspend on lid close and this will drain more power then the default. If you want to use suspend you can still issue it from command line.

1
  • Thank you for your answer and editing. Thought add a picture of the buds to make clear which ones I have. I'll give the non suspend a try, as we plugin in class, it does not really matter that much. Aug 9 at 15:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.