3

So i have to install libgnuradio-osmosdr0.1.4 package for a project but it gets me this error:

$ sudo apt-get -y install libgnuradio-osmosdr0.1.4


Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libgnuradio-osmosdr0.1.4 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libgnuradio-osmosdr0.1.4' has no installation candidate

I tried apt update, but it doesnt work.

I am on ubuntu 20.04 and amd64

0

1 Answer 1

3

See the packages for Ubuntu for libgnuradio-osmosd: You need libgnuradio-osmosdr0.2.0 for all Ubuntu other then 18.04/Bionic.

If you can not use 0.2.0 then that means your project needs an upgrade to support it. That is the safest method; you could add the "universe" repository for 18.04 to your system and install libgnuradio-osmosdr0.1.4 from that and pin it but that is a temporary band-aid.

2
  • Thank you, it worked.
    – kaan kaya
    Aug 9 at 10:59
  • 1
    @kaankaya cool :) I was still adding stuff *like how to pin the 18.04 version if you reaaaaaaaaaaaaaaaaallly wanted that
    – Rinzwind
    Aug 9 at 11:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.