0

We are running ver. 20.04 LTS with LibreOffice ver. 7.3.5.2 and we can not get spellcheck to work in Writer. It capitalizes the first word after a period ok but that's it. We had no problems with Writer ver. 6.4.7.2 and it's still in use on another machine. We have used the same settings as that ver. 6.4.7.2 to no avail as well as just about every other combination of settings and it still won't work.

enter image description here

7
  • Open LibreOffice Writer. Clck on Tools > Options from the menu. Scroll down to Language Settings > Writing Aids on the left panel. Take a screenshot of the Options - Language Settings - Writing Aids Window. Upload the screenshot in your question.
    – user68186
    Commented Aug 8, 2022 at 20:07
  • There is the screen shot. Commented Aug 9, 2022 at 18:34
  • The screenshot looks OK to me. I have no idea what's wrong.
    – user68186
    Commented Aug 9, 2022 at 19:31
  • I have the same setup v7.3.5.2 on 20.04 LTS and there does appear to be an issue with LO Writer spellchecking which I have been unable to resolve yet. Maybe report your issue to ask.libreoffice.org/tags/c/english/5/writer to see if one of their experts have an answer for it. Share a link to your post in comments here and I'll keep an eye out for it...
    – graham
    Commented Aug 9, 2022 at 19:41
  • I have the same setup LibreOffice v7.3.5.2 on Ubuntu 20.04. Ican't reproduce the problem. See my screenshot.
    – user68186
    Commented Aug 9, 2022 at 19:52

1 Answer 1

0

From Ask LibreOffice which resolves the issue on my Ubuntu system.

The package required for LO is hunspell-en-gb and the safest way to install it (which I did) is with synaptic package manager which will include all the correct dependencies.

enter image description here

After installation the spellchecker works as intended.

enter image description here

6
  • Sorry, but that didn't fix it. I did both hunspell-en-gb and -us and neither fixed it. So, I did the whole writer package and that didn't fix it either. I hate to do it, but uninstalling and reinstalling LibreOffice may be my only option? But if the problem exists after that?? Commented Aug 10, 2022 at 16:31
  • Another item that I just remembered, LibreOffice doesn't recognize any USB memory stick also. Commented Aug 10, 2022 at 19:42
  • The last step? I uninstalled LibreOffice, then deleted everything that had the name libreoffice (directory's, files, etc.) left on the system, and then installed a fresh copy of libreoffice and used synaptic package manager to insure that hunspell-en-gb & us were installed. Guess what, the sucker still doesn't spell check and still doesn't recognize a USB memory stick! Would appreciate an alternative to libreoffice or better yet a fix to their bug(s). Commented Aug 10, 2022 at 21:21
  • did you try to reopen the same documents? If so, the attributes for those documents will already be saved with it. Try opening a new document from scratch and trying the spell checker. You'll need to ask a separate question about alternatives.
    – graham
    Commented Aug 11, 2022 at 5:29
  • I GIVE UP! I've tried everything discussed in this thread to no avail. This morning I gave it a final shot by uninstalling LibreOffice both from the Ubuntu Software function and again from terminal (apt-get remove --purge, clean and autoremove). Then installed it again via the Ubuntu Software function. The spell check and finding a USB memory stick problems still exist! Commented Aug 11, 2022 at 20:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .