0

I installed Ubuntu 22.04 months ago (kernel 5.15.0.41.44), I had no problem with wifi.

Last 3 days something is happening. when I start up my laptop everything seems fine, but after 3-5 minutes the device disconnects to wifi then reconnects and for some time keeps trying, lastly connection is lost.

When I connect to my phone's wifi and distance is very small, it's stable connection.

I tried almost everything, I restarted module, restarted network manager, turned off wireless power saver, updated to kernel 5.19.0 then downgraded to 5.18.15 and for about 15 minutes problem stopped, then again same hell started. I am really devastated, now I don't know if installing another wifi driver can help. I am using "Realtek-RTL8821CE". I've seen many questions like this and none of solutions have helped.

Recently, I've came across something. Some packeges don't upgrade, they are kept back. After I tried to install them individually with sudo apt install package-name this keeps coming: I assume error is caused by my wifi adapter. thank you for your time.

~$ sudo apt install ubuntu-release-upgrader-core
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
ubuntu-release-upgrader-gtk is already the newest version (1:22.04.12).
ubuntu-release-upgrader-gtk set to manually installed.
The following packages were automatically installed and are no longer required:
  chromium-codecs-ffmpeg-extra gstreamer1.0-vaapi libva-wayland2
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up rtl8821ce-dkms (5.5.2.1-0ubuntu10) ...
Removing old rtl8821ce-5.5.2.1 DKMS files...
Deleting module rtl8821ce-5.5.2.1 completely from the DKMS tree.
Loading new rtl8821ce-5.5.2.1 DKMS files...
Building for 5.18.15-051815-generic
Building initial module for 5.18.15-051815-generic
ERROR (dkms apport): kernel package linux-headers-5.18.15-051815-generic is not supported
Error! Bad return status for module build on kernel: 5.18.15-051815-generic (x86_64)
Consult /var/lib/dkms/rtl8821ce/5.5.2.1/build/make.log for more information.
dpkg: error processing package rtl8821ce-dkms (--configure):
 installed rtl8821ce-dkms package post-installation script subprocess returned error exit status 10
Errors were encountered while processing:
 rtl8821ce-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)
3
  • 1
    "Consult /var/lib/dkms/rtl8821ce/5.5.2.1/build/make.log for more information." What does it say? Welcome to Ask Ubuntu.
    – chili555
    Commented Aug 6, 2022 at 23:08
  • Look at the network logs with the terminal command: sudo journalctl -b 0 -u NetworkManager. Read man journalctl.
    – waltinator
    Commented Aug 7, 2022 at 4:08
  • thanks guys, after i wrote that question i installed kernel 5.17.15 and uninstalled 5.18. No more wifi fluctuation and kept back packages. at least for a day...
    – Dr. Jake
    Commented Aug 7, 2022 at 19:12

0

You must log in to answer this question.

Browse other questions tagged .