I am currently using Ubuntu 22.04. I have a USB type WiFi adaptor to connect to a wireless network, but on enabling the WiFi I do not see any network available to connect with. I have tried the available methods already, but it didn't work. On removing WiFi adaptor the WiFi option disappears from menu, so I am assuming the system is detecting the WiFi adaptor but showing no network to connect.

Wifi adaptor:

enter image description here

No wifi option on removing adaptor:

enter image description here

After adding wifi adaptor to the usb port:

enter image description here

Output of lsusb :

kumar@LianLi:~$ lsusb
Bus 004 Device 002: ID 174c:3074 ASMedia Technology Inc. ASM1074 SuperSpeed hub

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 258a:0049 BY Tech Gaming Keyboard
Bus 003 Device 003: ID 046d:c092 Logitech, Inc. G203 LIGHTSYNC Gaming Mouse
Bus 003 Device 002: ID 174c:2074 ASMedia Technology Inc. ASM1074 High-Speed hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 26ce:01a2 ASRock LED Controller
Bus 001 Device 004: ID 05e3:0610 Genesys Logic, Inc. Hub
Bus 001 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 001 Device 002: ID 0bda:f179 Realtek Semiconductor Corp. RTL8188FTV 802.11b/g/n 1T1R 2.4G WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  • Can you give us the name of the Wi-Fi adaptor? And can you add the output of lsusb(you'll need to write this into a terminal. you can open a terminal from the applications menu). And if you can spot which one is the Wi-Fi adaptor, can you add the output of "lsusb -D /dev/bus/usb/XXX/YYY" where XXX is the Bus number, and YYY is the device number written on the same line with the Wi-Fi adapter. If you can't find it just add the output of lsusb.
    – Emre Talha
    Aug 6, 2022 at 15:07
  • Thanks for your time in trying to help me . As i was not able to attach the output here so i have attached it in the question itself . Regarding the make of adaptor I was not able to find it as it only has written 802.11n on top of it and as I was not sure which one is the adaptor I attached the complete output . Hope it helps in understanding the issue . Aug 6, 2022 at 16:45
  • It seems as your Wi-Fi adapter is Realtek Semiconductor Corp. RTL8188FTV 802.11b/g/n 1T1R 2.4G WLAN Adapter, so the necessary numbers would be 001 and 002. So the second command would be lsusb -D /dev/bus/usb/001/002. I assume that you have the Wi-Fi adapter still on the same USB port on your computer, if you plugged your Wi-Fi adapter on an other USB port you'll need to adjust the numbers accordingly.
    – Emre Talha
    Aug 6, 2022 at 17:07

1 Answer 1


So your Wi-Fi adapter need an additional driver.

In order to install the driver you'll need to enter these commands sequentially on a terminal. As these command require sudo privileges, you'll need to enter your user's password when asked. (For security, no characters will be shown when entering a password. After you've typed your password, press Enter and the command will do it's job.)

sudo add-apt-repository ppa:kelebek333/kablosuz
sudo apt-get update
sudo apt install rtl8188fu-dkms
  • "can't put the interface output here as it is quite long" Please put the output here and give us the link: paste.ubuntu.com
    – chili555
    Aug 6, 2022 at 21:31
  • 1
    I still have submitted the output which is accessible by here -paste.ubuntu.com/p/t4hV3ZFRkd . So , the steps that i followed after running above three commands are as : After downloading those drivers i opened the folder and opened readme file and found out these drivers have some issue with kernel 5.15 ( my current kernel) . So , i followed the instructions given the file and at the end when I checked for one last time I found my issue was solved . Hats off to the hard working and dedicated members for helping us selflessly . Aug 6, 2022 at 22:17
  • Will the solution work if my wifi-adapter is different, say, rtl810xe?
    – mandudeman
    Oct 13, 2022 at 0:24
  • It says that it is unable to locate package rtl810xe-dkms.
    – mandudeman
    Oct 13, 2022 at 0:28
  • @mandudeman Please start your own new question.
    – chili555
    Oct 13, 2022 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.