0

The error I get when trying to import a meson.build file is: "Could not load project management plugin KDevMesonManager. Check that the required programs are installed, or see console output for more information."

I have tried enabling the meson plugin in "configure kdevelop" -> "plugins", but it will not turn on. I check the check box next to "meson project manager" and click apply, but when I close the plugin window, try to import the project, get the above error, and then reopen the plugin menu, the plugin is unchecked!

I tried to enable the meson manager, close the program and reopen it, but it is disabled! The only time it isn't disabled is right after I enable the plugin and reopen the window.

Is there a way to import a meson project?

3
  • Do you have meson installed? And what does console output say?
    – arrowd
    Aug 5, 2022 at 8:20
  • Turns out it relied on some other project manager plugin that wasn't on by default. I ended up enabling all of the project managers and then it worked.
    – John Glen
    Aug 5, 2022 at 21:25
  • I must say, I am glad I got it working because kdevelop's static analysis is far better than every other IDE I have tried so far. I only wish you could add custom build and run commands.
    – John Glen
    Aug 5, 2022 at 21:26

0

You must log in to answer this question.

Browse other questions tagged .