0

I have a Dell g5 5590 (Nvidia rtx 2060) with dual boot (Windows 10 and Ubuntu 20.04) that suddenly started to get stuck after the login screen.

If I use the "nomodeset" parameter, I get a black screen after logging in. If I don't, I get a purple screen after logging in.

I've tried lots solutions I found online, here are them:

  • Renamed .config to .config_backup

  • Added the pci=noaer parameter to GRUB

  • Added nouveau.nomodeset=0 to GRUB

  • Created and logged in as a new user "test"

  • Purged nvidia drivers and re-installed them (nvidia-drivers-440 first, then nvidia-drivers-515)

What else can I try to fix this? How else can I try to troubleshoot this issue?

EDIT: It's worth mentioning I've also tried to boot in "safe mode" (or recovery mode) and the same issue happens.

3
  • Maybe wait longer with the black screen especially if booting on hard disk. Aug 4, 2022 at 15:01
  • I wasn't giving much time for it to load, but even after waiting hours, it's still stuck.
    – 大朱雀
    Aug 4, 2022 at 21:28
  • Then you should try to access the boot messages. An option file exists for GRUB where you can choose to display those messages. They must be also recorded somewhere. Aug 6, 2022 at 10:04

1 Answer 1

1

If you tried everything above and failed, I have another option for you:

  • Install lightdm and switch to it. (there are tons of tutorials on google)

That's what solved the issue for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .