It's weird that creating desktop shortcuts is currently so primitive.

I found the following: Create Shortcut / launcher on Desktop in Ubuntu 12.04

That helps. However, if there's something wrong with the shortcut, it just doesn't do anything. For instance, I tried to create a shortcut for this command line to create a shortcut. When I double-click it, it just does nothing.

This is the resulting text of my "Create Desktop Shortcut.desktop" file on the desktop:

[Desktop Entry]
Exec=/usr/bin/gnome-desktop-item-edit ~/Desktop/ --create-new
Name[en_CA]=Create Desktop Shortcut
Name=Create Desktop Shortcut

As I said, when I double-click this, or right-click it and select Open, nothing happens. Is there a log file where something about this would be written to?


8 Answers 8


To create Desktop shortcuts in Ubuntu,gnome-panel package is required first.

  1. Open Terminal. To open terminal click the Dash home from Unity launcher. And type terminal in the search field. And click Terminal.

  2. Type the below code in terminal and hit enter.

    sudo apt-get install --no-install-recommends gnome-panel
  3. Then type below code in terminal and hit enter

    gnome-desktop-item-edit ~/Desktop/ --create-new
  4. The create launcher window will pop-up,Type application name in the name field and type application name or path or browse in the command field. And click OK button.


    Example: CinePaint

  5. Now check your desktop for the shortcut.

    desktop shortcut

  6. If you want your shortcut to appear in the Unity launcher panel (the pop-out one on the left), you can drag it there from the desktop.

  • This no longer works when using smb// location of a network drive. I think it has something to do with the terrible new Nautilus. Do you know if there is an app out to create shortcuts to network locations, or has this now been abolished? Thanks
    – pst007x
    May 30, 2013 at 19:43

The following line is the culprit:

Exec=/usr/bin/gnome-desktop-item-edit ~/Desktop/ --create-new

The user HOME path ~ will not be expanded in a .desktop file. Please use to full path to get it working:

Exec=/usr/bin/gnome-desktop-item-edit /home/<user>/Desktop/ --create-new

Found it utterly simple to create shortcuts (on your desktop or anywhere else) in Ubuntu 12.04:

  1. Right click on the file or folder
  2. Click on "Make Link"
  3. A link will get created (folder icon with a curvy arrow)
  4. Cut/copy and paste the link wherever you choose to

I have seen that this works as well for executables / programs.

  • 4
    This is not a shortcut; it's a symbolic link. The command used in the background for this is ln.
    – glarrain
    Apr 27, 2014 at 14:24

My experience with 12.04 in this respect is utterly weird. First of all, when I "upgraded" from 10.04 to 12.04, most of the previous desktop icons survived the transition and worked. The old Open Office icons were there, but did not work because the programs had been removed in the course of the upgrade.

For some programs, such as Calculator, I find that I can just drag the icon from the Dash to the desktop, and it works right away. For others, such as all of the Libre Office programs, the dragged item does not work but gives a message of "broken link." There is no possibility of fixing it, because when you right-click it and look at the Properties, you cannot edit the command field.

The suggestion to find the application in /usr/share/applications and use "Make link" never worked for me because "Make link" was gray on all the icons I looked at. Dragging or copying from this directory also produced "broken link" messages.

How to get good desktop shortcuts for ALL installed programs -- shortcuts that both work right and look right -- is still for me an open question.

I was able to get working icons for these programs by (a) noting down the "command" found by right-clicking on the icon in /usr/share/applications and selecting Properties, and then (b) using the gnome-desktop-item-edit program in a terminal window to create the icon and then right-clicking on it, selecting Properties, and editing the Command field to show the command noted in step (a). This process gives a working icon, but it does not have the proper picture. Rather, the picture is always just the Gnome footprint symbol.


The simplest answer is this: drag the software icon to the desktop, right-click on it and select PropertiesPermissions tab → check mark the "Allow to Execute" (or something like that) checkbox. Voila.


Another method is searching for the application within the Unity dash and dragging it over to your Desktop as a shortcut/launcher. You can then modify an existing one by right clicking on it and modifying it's properties, or editing the .desktop file in a terminal if you prefer.

  • 1
    note that this only works for applications with a desktop file in /usr/share/applications/ (eg: most apps installed with apt-get). You can, however, drag a .desktop file from the desktop into the Unity launcher after creating it with eg mitch's instructions.
    – drevicko
    Jul 5, 2012 at 23:37

Let us assume your source folder is in directory '/home/blah/' and you want to move it to Desktop. How about you create a link to the folder* in ' /home/blah/' and then drag and drop the link to your desktop. The link is a shortcut to the folder.

  • you can create a link to a folder by right clicking and then clicking 'Make Link' in ubuntu 12.10 ( and perhaps also in older versions)

If you don't have a contextual menu for this purpose (12.04 doesn't have it by default) The best and easiest option for me is to install ubuntu-tweak:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

In the Administration → Personnal panel of this tool add the script Create a new launcher

Now when right clicking on the desktop, in the Scripts sub-menu you will have an entry: Create a new launcher

PS: Sorry, not sure about the translations, I have it in French.

Not the answer you're looking for? Browse other questions tagged .