I use Ubuntu Mate 20.04, and just today I did an update. Not sure if it is because of that, but now I cannot print. I use an Epson Stylus SX115.

If I call system-config-printer, I get this state:


If I click on "Print test page" here, it works; if I click on "Print self-test page", it does not.

Now, I open a PDF document in the default PDF viewer on Mate, which is Atril Document Viewer. I choose File/Print there, I get this:


I have two entries from the printer, because troubleshooting earlier told me to enable some print server, but it makes no difference, both of them show the same problem.

I click on Print on this dialog, and I get this - "Print error" "There was a problem processing document ..." :


Unfortunately, there is no indication on what the error is - though just now I notice "0K" under Size ...

If I click Diagnose, I get to this:


... and then when I click Forward (for the second entry, which is what I've used so far):


I get:

There are status messages associated with this queue.

The printer's state message is: "Rendering completed".

Eh, great - this tells me nothing. If I click Forward here, I get option to Enable Debugging, where it gets stuck (and so I get repeated offers to Enable Debugging, even if I tried that several times before).

Obviously, at least some part of the printing works, since I can do "print test page" - but how can I get a PDF to print from the default PDF viewer?

EDIT: If I do, from the command line (via Linux: How to print PDF files from the command line - makandra dev):

lp /path/to/file.pdf

... then Printing starts (and works) - but of course, I cannot change any print settings from a Print dialog.

  • 1
    Would try installing gnu-print(not sure of name). Have 20.04 also, could get my printer to print one job, but it never could get to the finish notice, had to reboot the printer all the time for next job.
    – crip659
    Aug 1, 2022 at 17:33
  • Thanks @crip659 - I cannot find anything "gnu-print", do you mean gpr (which I just learned from from askubuntu.com/questions/1370443/… ?) I tried it, it asks for a .ppd file, but when I use the one that is apparently used by cups for my printer /etc/cups/ppd/Epson-Stylus-SX110.ppd, it says it is an invalid ppt file ...
    – sdaau
    Aug 1, 2022 at 17:36
  • well, I did sudo apt install evince, then evince /path/to/file.pdf from the command line - and this seemingly works/prints; though I'd love to know how can I get the default PDF viewer to work too ...
    – sdaau
    Aug 1, 2022 at 17:43
  • 1
    I installed gutenprint package. Seems Ubuntu use to have it but was removed for 20.04(or slightly before). It seems to help with printers that the basic cups can't handle as well. My memory not as good as I thought.
    – crip659
    Aug 1, 2022 at 17:45


You must log in to answer this question.

Browse other questions tagged .