33

I'd like to have all of my windows open in the center of my screen instead of the top left corner. Is this possible? If so, where do I configure this?

3 Answers 3

28

If you are using Gnome with Compiz, install CompizConfig Settings Manager.

  • You can find it here:

enter image description here

  • Or install it via Terminal:

    sudo apt-get install compizconfig-settings-manager
    
  • Then open it and go to Window Management > Place Windows, enable it, and in "Placement Mode" choose Centered.

1
  • compiz has been removed from Debian, as mentioned here.
    – 0 _
    Commented Mar 8, 2016 at 20:32
24

For newer version of gnome (3.14 or higher) compiz has been removed. you can now Open windows in center of screen by check center-new-windows in /org/gnome/mutter/ using dconf-editor.

4
  • Does that work for Unity as well?
    – orschiro
    Commented Oct 22, 2016 at 12:50
  • 2
    This should be the accepted answer, as it works out of the box and is just a small change.
    – rugk
    Commented Jul 29, 2018 at 14:19
  • 1
    Actually I opened a bug report to make this setting the default: gitlab.gnome.org/GNOME/mutter/issues/246 IMHO, everything else makes no sense. Feel free to upvote it. :)
    – rugk
    Commented Jul 29, 2018 at 14:33
  • the perfect answer I was looking for. Thanks
    – Mejan
    Commented Jul 16, 2021 at 12:47
15

Actually, in recent versions of Ubuntu it is enabled by default. And since GNOME v3.30 there is also a visible option in GNOME Tweaks:

GNOME Tweaks with Windows->"Center New Windows" highlighted

Just select "Center New Windows" under "Windows".

5
  • Since this, and the original answer, both involve tweak tools I’m leaving the original answer as the main one. Yours is still a valued answer. Thank you
    – Frantumn
    Commented Dec 21, 2018 at 2:43
  • 1
    @Frantumn No, they don't both involve tweak tools. "Compiz" is a whole new window manager and a lot more. My answer is a nearly built-in tool in GNOME that just extends the settings. Using "Compiz" is a complicated workaround that I am not sure whether it still works anyway in recent Ubuntu versions.
    – rugk
    Commented Dec 22, 2018 at 17:30
  • Also see my comment: "in recent versions of Ubuntu it is enabled by default". As such the whole question is more or less obsolete now.
    – rugk
    Commented Dec 22, 2018 at 17:31
  • BTW, in contrast to what i said, (that it's the default in Ubuntu now) this topic is not dead and still in discussion in Fedora & Ubuntu.
    – rugk
    Commented Mar 30, 2019 at 15:15
  • 1
    this was disabled in ubuntu 20.04 lts for some reason
    – dkocich
    Commented Nov 13, 2020 at 6:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .