lsusb output:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 2d95:600a vivo V2152
Bus 001 Device 002: ID 0bda:b711 Realtek Semiconductor Corp. RTL8188GU 802.11n WLAN Adapter (After Modeswitch)
Bus 001 Device 005: ID 30fa:0300  USB OPTICAL MOUSE 
Bus 001 Device 004: ID 413c:2113 Dell Computer Corp. KB216 Wired Keyboard
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  • What have you tried? What's your hardware setup?
    – frippe
    Jul 31, 2022 at 9:35
  • I have tried all the things which i found from the internet Jul 31, 2022 at 9:39
  • @frippe please check my hardware config in below image ibb.co/5Ys2hLJ Jul 31, 2022 at 9:43
  • It is not a related hardware config. Please edit your question and add output of lspci -knn | grep Net -A3; rfkill list terminal command. Please post it as text, not as a screenshot.
    – Pilot6
    Jul 31, 2022 at 9:56
  • @Pilot6 this command does not return anything Jul 31, 2022 at 10:00

2 Answers 2


My WIFI issue is resolved. i have installed RTL8188GU driver and reboot the system.

Please follow the below steps:

sudo apt-get install build-essential git dkms
git clone https://github.com/McMCCRU/rtl8188gu.git
cd rtl8188gu
sudo make install
sudo reboot

After rebooting the system check WIFI should work.

  • This is great that you found the solution! But if there is a dkms install way, it is better to use that method because installing with make will break after a kernel upgrade. The dkms in the first line suggest that the author has a dkms method too.
    – Pilot6
    Jul 31, 2022 at 10:46
  • @Pilot6 so i have to install dkms? Jul 31, 2022 at 10:49
  • You already installed dkms, but the installation procedure didn't use it.
    – Pilot6
    Jul 31, 2022 at 10:50
  • I looked into that git readme and it doesn't have dkms.conf. So you'll need to re-install the driver starting with cd rtl8188gu after each kernel upgrade, unless you create a dkms. And you don't need sudo apt install --reinstall linux-firmware.
    – Pilot6
    Jul 31, 2022 at 10:52
  • Okay, so did you know how to use it. because i don't want to face any problem when kernel is upgrade Jul 31, 2022 at 10:53

I tried running

"sudo apt-get install build-essential git dkms"

but it is showing me error as:

Package 'build-essential' has no installation candidate.

  • Hi and welcome to Ask Ubuntu! It seems you may have added a comment in the answer section though. If you need to update your question with more info, feel free to edit the question at any time. May 25 at 14:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .