I had a VM with Ubuntu 21.04, I deleted it and I have made a new VM with OS Ubuntu 22.04.

On the previous OS, I was used to enable:

  • Guest additions CD: from menu devices>insert guest additions CD -> this enabled screen enlargment with right CTRL+F
  • shared clipboard: devices>shared clipboards>bidirectional -> this enabled copy&paste from my host to my virtual machine and vice versa.
  • shared folder: devices>shared folders>settings> various choices -> this enabled file transfer from my host to my virtual machine and vice versa.

I did the same on the new VM with Ubuntu 22.04, rebooted various times from OS menu, but the changes do not take place:

  • right CTRL+F changes only the VM window size, but does not enlarge the screen.

  • Copy&paste does not work from my host to my virtual machine (CTRL + SHIFT + C , CTRL + SHIFT + V) and vice versa (CTRL + C , CTRL + V).

  • the shared folder I configured is not present at path /media/

What could be the cause of it? How can I solve it?


The Guest additions CD / screen size point is SOLVED.
I solved by setting the hosted OS screen resolution to the desired size from OS menu settings>displays>resolution>(put the same resolution of my host OS).

Though, have created a new VM and installed ubuntu 21.04 and did the same configuration operations that I did for Ubuntu 22.04.
For Ubuntu 21.04, it is not necessary to set the size resolution from the OS settings menu to make the screen enlargement via right CTRL+F work.
Furthermore, in Ubuntu 21.04 it is sufficient to run the operations that I have described upwards to make the shared folder and shared clipbord work.

I also deleted the VM with Ubuntu 22.04, generated a new VM, installed the 22.04 OS again, and still I get the same problems. Maybe something is wrong with my Ubuntu 22.04 iso:
ubuntu-22.04-desktop-amd64.iso - 3.569.249 KB - from https://releases.ubuntu.com/22.04/

  • 2
    Is your version of VirtualBox fully updated? An out-of-date VirtualBox may cause this problem.
    – ArrayBolt3
    Aug 1, 2022 at 0:31

1 Answer 1



It turns out that on Ubuntu 22.04 the process of installing the VirtualBox Guest Additions is a little bit more manual than the one I rmembered for Ubuntu 21.04.

First I have updated Virtualbox from 6.1.22 to 6.1.38:

  • close all the processes and then shut down the VM.

  • update virtualbox

  • restart the PC

  • start virtualbox and the VM

Then run

sudo apt update
sudo apt install -y build-essential linux-headers-$(uname -r)

From the VirtualBox topbar menu: Device > click on Insert guest additions CD

create a folder where to place the installation content

sudo mkdir -p /mnt/cdrom

Mount the CD

sudo mount /dev/cdrom /mnt/cdrom

run the installation software in the mount

cd /mnt/cdrom
sudo ./VBoxLinuxAdditions.run

Reboot the VM

sudo reboot

The quickest way to check if the installation worked is to test the screen enlargment, by pressing CTRL(right) +F

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .