0

Today I had to change the motherboard in my Dell XPS 13 7390. Since then the screen is constantly flickering and showing weird lines.

I'm using ubuntu 22.04. I've already checked this issue and other issues that seem similar.

I've tried to load a live USB and it happens the same if I run ubuntu from there.

The flickering happens once the OS is loaded. There is no flickering on the initial page where I decrypt the hard drive.

enter image description here

Update:

When using recovery mode everything works fine. The difference is that it's using llvmpipe (LLVM 13.0.1, 256 bits) instead of Mesa Intel® UHD Graphics not sure what's the difference though

1
  • 2
    Welcome to AskUbuntu! Have you tried booting into other operating systems, or a live USB and seeing if the behavior replicates itself there? Does this issue only appear once the OS is loaded, or does it appear during boot, in the BIOS and grub as well? Please edit your question with some more information to help us help you :)
    – David
    Commented Jul 28, 2022 at 23:06

3 Answers 3

1

Looks like updating the BIOS, the kernel, and the grub did not help.

Reinstalling Ubuntu with NOMODESET mode

I am going to guess that you have a Ubuntu live USB/CD prepared.

  1. Plug your USB into your computer and boot from it.

  2. Once you get to your installation menu, click F6 to enter other options.

  3. Now, scroll down (using the arrow keys) and press enter on nomodeset

  4. Install Ubuntu.

3
  • I did something similar and it worked out. I've set the nomodeset in grub, explain in this question. Is it good it's using llvmpipe instead of Mesa Intel® UHD Graphics Commented Aug 1, 2022 at 14:26
  • @fritsMaister If it worked, please accept the answer. Commented Aug 1, 2022 at 19:50
  • Since I set the nomodeset the USB to HDMI adapter doesn't work. Any idea? Commented Oct 24, 2022 at 15:11
0

Try updating your BIOS, GRUB, and kernel.

Download BIOS updates from:

https://www.dell.com/support/home/en-nz/product-support/product/xps-13-7390-laptop/drivers

Then choose BIOS in the "Operating System" dropdown menu:

Update GRUB by running:

sudo su

Type in your password when prompted.

Then:

update-grub

Update kernel by running:

sudo apt-get dist-upgrade

Type in password if prompted.

4
  • I've updated the BIOS, the kernel, and the grub. And nothing, same situation. Commented Jul 31, 2022 at 8:26
  • Is it okay for you to reinstall Ubuntu? I will post another answer tomorrow. See that one. Commented Jul 31, 2022 at 8:27
  • I did reinstall ubuntu and format everything. I'm not sure about the difference between llvmpipe (LLVM 13.0.1, 256 bits) and Mesa Intel® UHD Graphics and why it works well with llvmpipe Commented Jul 31, 2022 at 8:30
  • Let me post answer. Try that one. Commented Jul 31, 2022 at 8:32
0

If updating all the software and mid-ware doesn't help, make sure that every other component is connected well and not loose anywhere. Motherboards take anything from random access memory (RAM) to graphics processing units (GPU) and the central processing unit (CPU), any one of which can cause something like this to happen if they're not installed properly.

Be careful to handle this hardware as well as possible. Many guidelines have said to wear gloves to avoid accidentally dirtying the system, eliminate static charge that could surge through the system and damage it, push components into connections evenly instead of wobbling them left to right, and be careful not to force components to connect where they shouldn't.

2
  • The motherboard was changed by a Dell support person. I've updated everything and I'm still wondering if it's a software or hardware issue. I'm not sure about the difference between llvmpipe (LLVM 13.0.1, 256 bits) and Mesa Intel® UHD Graphics and why it works well with llvmpipe Commented Jul 31, 2022 at 8:28
  • If the problem wasn't fixed when updating all of the software, resetting the system's mid-ware (BIOS, kernel, grub, etc.), or even reinstalling the entire operating system, then the only way it could be a software issue is if the software in charge of running Mesa Intel has a problem. If it doesn't, then that only leaves hardware. Commented Aug 2, 2022 at 1:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .