19

I've been an ubuntu user for the last 5 years, I newly upgrade from 20.1 to 22.04 and my settings aren't working, I tried to install the gnome-control-center but the terminal reply me with the following:

The following packages have unmet dependencies:
 libpython3.10 : Depends: libpython3.10-stdlib (= 3.10.4-3ubuntu0.1) but 3.10.5-1+focal1 is to be installed
E: Unable to correct problems, you have held broken packages.

What can I do to make the settings work?

1

2 Answers 2

49

Probably this was due to a recent update. At least this was the problem for me.

The following procedure solved my issue:

sudo apt-get update
sudo apt-get install --reinstall gnome-control-center

Then I restarted gnome-control and reopened the display with the following commands:

gnome-control-center display
gnome-control-center

I hope this helps.

3
  • 4
    One would think this issue of display settings would be resolved in 2023. I confirm that the reinstallation of the gnome-control-center did the trick.
    – Lutz Filor
    Mar 20, 2023 at 22:58
  • Thank you. This worked for me on Ubuntu 22.04.3 LTS
    – Ram Fattah
    Dec 27, 2023 at 22:48
  • "I hope this helps.": you bet!! ... it did in my case...Thank You!
    – darbehdar
    Jan 28 at 7:47
1

For me, it was the power setting issue. I set it to the performance mode instead of Balanced or Power Saver.

Try changing by:

$ powerprofilesctl set balanced

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .