2

After upgrading my system from 21.10 to 22.04 it does not boot anymore.

Let me describe my setup first: I do have two SSDs combined in a Raid 0 (Intel Rapid Storage Technology). This is where my main system is installed. There is a fat32 boot partition (EFI System Partition) and the rest is an ext4 pratition for the root file system. I also have a HDD outside of the raid array, which is just there for data and backups.

This setup worked nicely for quite a while and survived multiple Ubuntu upgrades.

Now, when booting the system I get the message that the system gave up waiting for the root file system device. It also tells me the UUID of the ext4 partition, which is actually the right one. Then the system falls back to the initramfs shell.

In the shell I can actually see that some kind of raid devices were assembled. I have /dev/md126 and /dev/md127.

But when I try to mount /dev/md127 to a newly created directory I just get an error message like this:

EXT4-fs (md127): unable to read superblock

Now, one might think that the device or at least the raid array is broken. But that's not the case. I used a live usb version of Ubuntu (also 22.04) to boot my machine. The system does also not recognize the raid array on the fly. But it works after running following command:

sudo partprobe /dev/mapper/isw_bbfdhiijgj_SSD

After running this, I can immediately use nautilus to browse the whole filesystem without problems. All the files are there and work. At this point I could also verify that the UUID used in the boot process is the right one.

What I tried so far to solve the problem:

  • Used boot-repair, it did not make a difference
  • Chrooted into the system, uninstalled, reinstalled und updated the grub config and rebuilt initramfs

None of this was successful so far.

So, what can I do to fix the booting process?

3 Answers 3

1

Edit #2: I had a possibly similiar problem but I was able to fix it with boot-repair.

I believe I may be having the same problem as you, but I'm getting a bit stuck. I'm not super knowledgeable about Ubuntu but I'm also dropping into initramfs and have an Intel RAID 1. I just checked the /etc/fstab and it does have what I believe to be the correct information:

/dev/mapper/isw_chjfachhgg_ARRAY1 / ext4 errors-remount-ro 0 1

However, I'm not sure if I need to do something additional to make it actually boot from this drive. I was able to boot to a USB and everything on the drive looks perfectly fine.

This occurred after an attempted upgrade from 20.04 to 22.04. There were some messages during the upgrade and it's possible something didn't install correctly. I am going to try boot-repair now and see if I can get it fixed. If anyone has a suggestion I would greatly appreciate it; naturally this occurred when I have a busy work weekend planned.

https://paste.ubuntu.com/p/RXf5Xk6fqV/

2
  • I'm glad that boot-repair fixed your problem. It's a really cool tool when it works.
    – Alex
    Dec 10, 2022 at 13:24
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Dec 15, 2022 at 12:04
0

Just a little update: I was still not able to make the machine boot from the raid array.

However, I have now copied all of the data from the raid array with rsync -a to my HDD, chrooted into the copied system, ran update-grub and then grub-install. After this procedure I was able to boot into the "old" system on the HDD, which worked quite well despite being slow as hell (going from 2xSSD raid0 to spinning disc HDD...).

So, this is not a complete solution to the actual problem of not being able to boot from the raid array, but at least I got my system and data back up and running. Maybe this will help other people with the same problem as well.

0

similar problems on a system with Windows, Fedora, and Ubuntu installed on different LVM partitions on a intel bios raid 0. After upgrade from Ubuntu 20.04 to 22.04 the system does not boot into ubuntu 22.04 (the other os's still boot fine). It drops into the initramfs shell.

I made a number of attempts, tried repairing boot and grub from live cd, nothing worked. in the shell after the install before reboot things looked fine, but then after reboot even in live cd it could not recognize the partitions correctly.

I eventually wiped the other os's, and stopped using lvm, to see if giving ubtunu full control and keeping it simple would do the trick. No luck. It seems that the 22.04 has some trouble with Bios raid.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .