12

I am trying to mount an external disk on Ubuntu 22.04, and get the following error:

mount: /media/destdrive: unknown filesystem type 'exfat'.

This was working yesterday, but has stopped working since a reboot (!)

It's Ubuntu 22.04 (so exfat should be installed - no need to install eg exfat-fuse), running in a Hyper-V VM on Windows 11.

The kernel is 5.15.0-1014-azure

cat /proc/filesystems doesn't include exfat

Here is the output of find /lib/modules/ -iname '*exfat*':

/lib/modules/5.15.0-41-generic/kernel/fs/exfat
/lib/modules/5.15.0-41-generic/kernel/fs/exfat/exfat.ko
/lib/modules/5.15.0-27-generic/kernel/fs/exfat
/lib/modules/5.15.0-27-generic/kernel/fs/exfat/exfat.ko

Also, I have tried on Ubuntu 22.04 running directly on WSL2 and am getting the same error.

Maybe I have accidentally installed something or done something to stop it working?

Any help in troubleshooting or fixing this would be much appreciated - thank you!

1 Answer 1

15

I believe you have provided the answer yourself (in your very detailed and well-written question, I might add).

When listing modules, you can see that the exfat modules are available for kernel 5.15.0-27-generic and 5.15.0-41-generic. And yet, you state that you are now (for unknown reasons) running kernel 5.15.0-1014-azure.

I believe you should revert back to running the latest generic kernel 5.15.0-41-generic, and by doing this I also believe exfat will be working again.

3
  • Thanks Artur! I have reverted to the latest generic kernel and that seems to work. I have 2 follow up questions though: a) Any idea why 5.15.0-1014-azure doesn't support exfat? b) Ubuntu 22.04 running under WSL2 doesn't seem to either (kernel 5.10.102.1-microsoft-standard-WSL2)
    – Neil D
    Jul 25, 2022 at 16:40
  • 4
    As for a) I would imagine that Azure (since it's a cloud-kernel) does not expect exfat usage, and b) No clue. 😉 Jul 25, 2022 at 16:50
  • 3
    I would guess it's the same reason for WSL2: they expect that exFAT volumes will be shared from host, rather than mounted directly inside WSL.
    – gronostaj
    Jul 26, 2022 at 7:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .