This question already has an answer here:

I installed Ubuntu yesterday via a bootable USB drive, created with unetbootin. Everything went very well, but now the computer does not boot unless the USB drive is plugged in. If it's not, then when the computer boots, the boot sequence screen just appears and if I select the hard drive, it will just reboot and go back to this boot sequence screen, until I plug in the USB drive.

Any ideas? Thanks a lot for your help!

UPDATE: Having some valuable data on the machine, I would prefer a solution that doesn't involve reinstalling, but from the first replies, I guess this may be what I have to do eventually. Thanks!



EDIT: output of sudo fdisk -l below

Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x000742dc

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048  1449474047   724736000   83  Linux
/dev/sda2      1449476094  1465147391     7835649    5  Extended
Partition 2 does not start on physical sector boundary.
/dev/sda5      1449476096  1465147391     7835648   82  Linux swap / Solaris

Disk /dev/sdb: 4009 MB, 4009754624 bytes
255 heads, 63 sectors/track, 487 cylinders, total 7831552 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

   Device Boot      Start         End      Blocks   Id  System
        /dev/sdb1   *        8064     7831551     3911744    b  W95 FAT32


EDIT2 bootinfo output: http://paste.ubuntu.com/1006423

marked as duplicate by David Foerster, Eric Carvalho, karel, Fabby, Kevin Bowen Jun 14 '18 at 22:12

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I think you should change the partition numbers in your grub menu. When you go to the boot menu press e(to edit) and change the partition numbers accordingly. You should also change the UUIDs too. – Manula Waidyanatha May 25 '12 at 9:19
  • Please post the output of sudo fdisk -l – jPlatte May 25 '12 at 9:44
  • Done. I didn't know how to put it down there so I've edited the main message. I had the USB plugged in, so that would be the second drive then. Thanks. – gmer May 25 '12 at 10:28
  • @Manuela, how do I do this? Sorry, I'm not particularly good for this. Thanks a lot. – gmer May 25 '12 at 10:28
  • If you want to attempt to fix this the best approach would be to collect a bootinfo summary. That might give us an idea what is wrong with booting on your system. I tried to outline the steps for one way of doing this in this answer. Don't forget to add the URL of the pastebin to your question. – irrational John May 25 '12 at 12:55

It seems that Ubuntu has been installed in the USB instead of in the hard drive. This maybe related to a bug that is described (in Spanish) in the following address:


If this is the bug that affects you, it seems that can be solved using the following command:

sudo grub-install /dev/sda && sudo update-grub

Just make sure that this is the issue that affects you before using this workaround!

  • Thanks for your rapid reply. My problem seems identical to the one you describe, and to what I could get from the translation of the page you indicated. However, I did what you said and I still have the problem... Would there be something else to try? Thanks a lot. – gmer May 25 '12 at 10:04
  • I guess that the simplest (and safer) solution would be installing again Ubuntu. As this issue is only present when installing from the USB, maybe you could try installing it from a CD. Is that possible? – granadajose May 25 '12 at 10:25
  • That's probably what I will do if I can't solve this soon. Thanks for your help anyway – gmer May 25 '12 at 10:29

I have solved this problem thanks to help on another forum.

I used boot-repair, ticking "reinstall grub" as well as "purge and reinstall". When I had to reboot, the screen froze and I had to use the power button. But now it boots fine on the hard drive. I didn't have to make another partition.

Thanks everybody for your help.


Reinstall Ubuntu, but take attention at the moment the system ask you where your "boot" (grub) must be installed. Change it to (mostly) sda1 - not the usb stick.

  • Hmm, it doesn't seem I can do it from the USB drive then. When I boot on it, obviously, it just launches unbuntu! I'll try and do it via CD/DVD then. Thanks. – gmer May 25 '12 at 14:39
  • Why not? The question of ubuntu is to know where the grub must be installed (not ubuntu) (on you C drive i suppose) - and not on the usb. Can you be more clear? – Julien Chau May 25 '12 at 17:49
  • Sorry. When I am trying to reinstall using the same USB drive, and I choose USB in the boot menu, what it does is start ubuntu, not the install. I don't know if that makes sense now. Thanks for your help. – gmer May 30 '12 at 13:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.