Cocopa external DVD drive USB 3.0/Type-C not recognized by Ubuntu 22.04 on Dell Inspiron 16 7610.

  • Why do you say "not recognized"? How have you tried to use it? Jul 21, 2022 at 17:25
  • First of all just plugged in. Then followed recommendations at itsfoss.com/play-dvd-ubuntu-1310. Nothing I've tried works.
    – Peter
    Jul 22, 2022 at 9:50
  • So you're trying to play DVD-Video? Indeed your link matches the official instructions - help.ubuntu.com/community/RestrictedFormats/PlayingDVDs - but saying you followed a remote procedure says nothing about what really happened, if there were error, etc. And says nothing about the disk you're actually trying to read nor about what happens. Please edit the question and describe exactly what you did, what were the results and what type of disk you're trying to read and what happens when you insert it. Jul 22, 2022 at 10:15

1 Answer 1


The seller has now admitted that this device does not work with Linux.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .