I'm trying to install Ubuntu server 22.04 on my old PC. After setting up and clicking up install, in some time I can see an error report Sorry, there was a problem completing the installation

It occurs during installing kernel stage. I can see the next output at the end of full log:

curtin.util.ProcessExecutionError: unexpected error while running command.
Command: ['unsahre', '--fork', 'pid', '--', 'chroot', '/target', 'eatmydata', 'apt-get', '--quiet', '--assume-yes', '--option=Dpkg::options::=--force-unsafe-io', '--option=Dpkg::Options::=--force-confold', 'install', 'linux-generic']
Exit code: 100
Reason: -
Stdout: ''
Stderr: ''

My PC:

  • MB: Evga nforce 680i sli
  • Processor: Intel Core2 Quad CPU Q660 2.40GHz
  • 6 Gb DDR2 memory

What I've tried:

  • Installation with and without plugged ethernet cable
  • Installation with and without updating installer to latest version
  • Installing Ubuntu 20.04 server (same error)
  • Installation to different HDD (I've tried different SATA and IDE disks)
  • Installation with disabled network adapters (from here)

I should also mention that I've managed to boot live Manjaro distro sucessfully.

Let me know if I can add some more information about this. Thank you!

1 Answer 1


So, the problem was in damaged image. After burning my boot stick with fresh-downloaded image by another program, installation complete successfully.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .