4

Perhaps related to Modem-manager-gui breaks after update to Ubuntu 22.04 but I managed in that case by not using modem-manager-gui but mmcli.

Now, after a certain upgrade (perhaps 15 days ago) the modem is not getting active at all.

Modem is recognized as:

mmcli -L
    /org/freedesktop/ModemManager1/Modem/0 [Sierra Wireless, Incorporated] Sierra Wireless EM7455 Qualcomm Snapdragon X7 LTE-A

The SIM card is active and have credit. Is not even possible to initiate USSD commands.

When using an old ISO (Lubuntu 21.10) it works perfect.

4 Answers 4

2

In the newest version of ModemManager the automatic FCC unlock is disabled. You can see here: https://modemmanager.org/docs/modemmanager/fcc-unlock/ To use the modem again you must FCC unlock the modem.

For the Lenovo-shipped EM7455:

sudo ln -sft /etc/ModemManager/fcc-unlock.d /usr/share/ModemManager/fcc-unlock.available.d/1199:9079

2

Solved by installing libqmi-utils as suggested by https://bugs.launchpad.net/ubuntu/+source/modemmanager/+bug/1968581/comments/4

Not in the link, but I also restarted ModemManager service.

Now is just modem-manager-gui the one that is broken with the following output:

~ modem-manager-gui

(modem-manager-gui:6140): GLib-CRITICAL **: 00:07:51.363: g_strrstr: assertion 'haystack != NULL' failed
Connection manager: Network Manager >= 0.9.0
Modem manager: Modem Manager >= 0.7.0

(modem-manager-gui:6140): GLib-CRITICAL **: 00:07:52.063: g_strrstr: assertion 'haystack != NULL' failed

(modem-manager-gui:6140): GLib-CRITICAL **: 00:07:52.103: g_variant_lookup_value: assertion 'g_variant_is_of_type (dictionary,
G_VARIANT_TYPE ("a{s*}")) || g_variant_is_of_type (dictionary, G_VARIANT_TYPE ("a{o*}"))' failed

(modem-manager-gui:6140): GLib-CRITICAL **: 00:07:52.103: g_variant_lookup_value: assertion 'g_variant_is_of_type (dictionary,
G_VARIANT_TYPE ("a{s*}")) || g_variant_is_of_type (dictionary, G_VARIANT_TYPE ("a{o*}"))' failed

(modem-manager-gui:6140): GLib-CRITICAL **: 00:07:52.103: g_variant_lookup_value: assertion 'g_variant_is_of_type (dictionary,
G_VARIANT_TYPE ("a{s*}")) || g_variant_is_of_type (dictionary, G_VARIANT_TYPE ("a{o*}"))' failed

(modem-manager-gui:6140): GLib-CRITICAL **: 00:07:52.103: g_variant_lookup_value: assertion 'g_variant_is_of_type (dictionary,
G_VARIANT_TYPE ("a{s*}")) || g_variant_is_of_type (dictionary, G_VARIANT_TYPE ("a{o*}"))' failed

(modem-manager-gui:6140): GLib-CRITICAL **: 00:07:52.103: g_variant_unref: assertion 'value != NULL' failed
Segmentation fault at address: 0x20
Stack trace:
1. /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_bit_lock+0x50) [0x7f8d75cd7540]
2. /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_bit_lock+0x50) [0x7f8d75cd7540]
3. /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_variant_n_children+0x1d) [0x7f8d75d5137d]
4. /usr/lib/x86_64-linux-gnu/modem-manager-gui/modules/libmodcm_nm09.so(+0x3bc0) [0x7f8d70077bc0]
5. modem-manager-gui(mmguicore_connections_enum+0x6d) [0x55d2f3383d4d]
6. modem-manager-gui(+0x4a520) [0x55d2f33a4520]
7. modem-manager-gui(mmguicore_devices_open+0x1c0) [0x55d2f3388f90]
8. modem-manager-gui(+0x414fe) [0x55d2f339b4fe]
9. modem-manager-gui(+0x4a7a2) [0x55d2f33a47a2]

but I can manage with mmcli.

1

I had similar issue with Ubuntu 22 and Thinkpad Z13 in 2022:

gdbus.error.org.freedesktop.modermmanager1.error.core.wrongstate. cannot register modem: not yet enabled

The modem was disabled by default and no way to turn it on.


After hours of googling and trying various solutions with ls and modem enable/disable scripts, the libmbim-utils solved it:

$ sudo apt-get install libmbim-utils
$ sudo mbimcli -p -d /dev/cdc-wdm0 --quectel-query-radio-state
[/dev/cdc-wdm0] Radio state retrieved: 'fcc-locked'

$ sudo mbimcli -p -d /dev/cdc-wdm0 --quectel-set-radio-state=on
[/dev/cdc-wdm0] Successfully requested to enable radio
$ sudo mbimcli -p -d /dev/cdc-wdm0 --quectel-query-radio-state
[/dev/cdc-wdm0] Radio state retrieved: 'on'

Now the modem is enabled!



Credit goes to non-https website: https://koo.fi/blog/2022/12/21/enabling-quectel-em05-g-modem-on-linux/

1
0

This is the solution:

ln -sft /etc/ModemManager/fcc-unlock.d /usr/share/ModemManager/fcc-unlock.available.d/*

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Jul 30, 2022 at 13:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .