18

A few days ago I realize that the following message appears when booting Ubuntu 20.04 (it didn't appear before):

[   0.113770] x86/cpu: SGX disable by BIOS.

After a little research I found other people having this "problem". On the cases I saw the OS didn't even boot after that error (it seems because the OS doesn't detect the disks) but that's not my case, my disks are detected correctly and Ubuntu 20.04 starts as nothing happens.

So for me isn't really a problem but I'm concerned that it can turn into one. So I want to know if there's a solution. I searched on my BIOS but I didn't see an option that allows me to enable the SGX.

My Motherboard and CPU are 'MSI H510M Pro-E' and 'Intel Core i5 10400'(I use the integraded graphics, specifically are called 'Intel HD Graphics 630')

4
  • 1
    If it works then nothing to worry about. You can ignore it. There are many cases where the graphical desktop doesn't load for many different reasons. This and a lot of other messages - errors, warnings, etc. - are what people see so many wrongly assume their problem is somehow related with those messages. Jul 16, 2022 at 10:33
  • I have this message every time I boot my system. My system works perfectly.
    – mook765
    Jul 16, 2022 at 11:10
  • 2
    "I'm concerned that it can turn into one." It cannot. Also, SGX is deprecated now anyway, so it's not like stuff is going to start needing it. Jul 16, 2022 at 23:47
  • As @JosephSible-ReinstateMonica already mentioned, SGX got deprecated in 2021 because a number of vulnerabilities; so no worries. Oct 10, 2022 at 19:30

4 Answers 4

19

x86/cpu: SGX disable by BIOS

This message began to appear when you upgraded to kernel 5.13.

SGX stands for "Intel Software Guard eXtensions" and is "a hardware-based isolation and memory encryption mechanism provided by modern Intel® CPUs". In your BIOS you might find a switch with 2 or 3 possible options:

  • Disable: SGX instructions and resources are not available to applications
  • Enable: SGX instructions and resources are available to applications
  • Software Controlled: SGX can be enabled by software applications asking for it

If the option is not there you might get it through a BIOS upgrade. Otherwise, if you want to get rid of the message, add nosgx to the grub defaults (see How do I add a kernel boot parameter? on how to add a parameter). You can also safely ignore the message, as SGX is benign and not necessary.

3
  • 1
    I am getting this message while booting my ubuntu 20.04, do I need to ignore it or do I need to fix it? Sep 4, 2022 at 13:05
  • My BIOS offers only "Disabled" and "Software enabled". Thanks for the tip about the nosgx boot option !
    – MoonSweep
    May 20, 2023 at 8:38
  • @AlwaysSunny Good question. I was hoping to find an answer to this question here. I get this message booting Linux Mint 21.2 MATE on a DELL Laptop with Intel i7 CPU.
    – Andreas
    Dec 7, 2023 at 5:44
1

On my dual boot Acer laptop, I booted on Windows 11, installed the Intel Software Guard Extensions Activation App and enabled SGX as explained here: https://www.intel.com/content/www/us/en/support/articles/000058952/software/intel-security-products.html.

Nothing new appeared in the BIOS, but the x86/cpu: SGX disable by BIOS. message at boot is now gone.

0

For me this hang at SGX was caused by messing with X11/Synaptics config. If you did that, your solution maybe is to delete it's configs through recovery root terminal.

https://askubuntu.com/a/206289 desribes the needed step. You may also revert the changes you've made, seems like a much safer option than deleting it entirely.

I have no idea for why messing with config would have such dire almost untraceable implications. All i did are a couple of changes related to touchpad scroll speed.

0

Following the advice by Rinzwind, above, on my Dell inspiron E7270 laptop running mint 21.3 with kernel 5.15 I edited /etc/default/grub so that it now has nosgx added to my existing other parameters as follows:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noaer pcie_aspm=off **nosgx**

now the sgx message has gone. Thanks Rinzwind.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .