I just installed a fresh copy of Ubuntu 12.04 on a new Lenovo ThinkCenter from a USB drive. When I restarted after installation, the boot sequence didn't find the OS. Instead I got the no operating system found error. When I started Ubuntu from the USB, I could see the HDD and that it had all the installed files. I just couldn't boot into it. It appeared that GRUB was not at the right place or that there was something wrong with the UEFI and GRUB. What is the simplest way to fix these errors?

  • Just remove the bootable pen drive at the right time when after successful installation when the ubuntu prompts to restart. Also select the device while booting and then install. Apr 24, 2014 at 4:56
  • @iamd1 This doesn't work for most Lenovo BIOSes
    – cutrightjm
    May 15, 2014 at 16:39
  • I had the same problem on a Lenovo ThinkCentre M92p (Tiny). Make sure you set the bootable USB up by first formatting, then partitioning, then dd'ing the img file. I didn't partition, just formatted. It installed, but notably didn't mention where to install. Then it had this 1962 no operating system found problem. By starting again and partitioning the usb properly first, it worked. I found out by installing an earlier version to see if I got the same error (so an earlier Ubuntu version may also be an approach).
    – apg
    Nov 21, 2019 at 7:42

10 Answers 10


Ok...this took a lot longer than it should. But here it goes:

Installing 12.04 on a 64 bit system that supports UEFI booting like the Lenovo ThinkCentre will create three partitions on the system: a FAT partition for EFI, the ext4 partition for ubuntu and some swap. However, restarting the machine, I was not able to boot at all. Initially, the Intel Boot agent would kick in and try to boot from the network. Even if you turn that off, as indicated later, it still doesn't boot. It says no operating system found.

Now here are the things I tried that didn't work for me:

  1. Change the SATA controller type to IDE Using a boot repair disk (it doesn't know how to handle EFI with GPT partitioning)
  2. Changing the order of the boot sequence to put HDD first
  3. Changing the boot mode from UEFI, to Legacy or to Auto
  4. Recompiling GRUB2 and putting it in the UEFI paritition, as indicated here:https://help.ubuntu.com/community/UEFIBooting

The first good direction I got was from this UbuntuForums thread.

People were having problems with earlier versions of Ubuntu. One of the suggested solutions is to install 10.04 first, and update from there.

What this really does is forget UEFI altogether, and create just two partions..the ext4 for ubuntu 10.04 and swap. You could then upgrade to ubuntu, which keeps the same partitioning. A couple things to note...mind your architectures, since this particular machines support 64 bit or 32 bit, so the 10.04 you install first should have the architecture you intend to keep. Also, your network card will likely not work on the 10.04 kernel, so you will have to upgrade from the cd by installing the alternate iso. Follow these instructions: https://help.ubuntu.com/community/PreciseUpgrades#Upgrading_Using_the_Alternate_CD.2BAC8-DVD .

What I did instead was, First installed 10.04, then install ubuntu 12.04 again, but go to 'do something else' on the partitioning page...and i simply chose to reformat the main ubuntu parition and leave the swap as is (mind you, after 10.04 you probably have only those two partions on the HDD you installed the ubuntu on). [in retrospect, I could just have created those partions without installing 10.04, it seems]

Once installation is done, I restarted, but was greeted with an error "invalid arch independent ELF magic". Looking this up indicated that grub was probably from a previous version of ubuntu,and needs to be installed again. I had to boot from the liveCD/USB again, and reinstall grub2 (you can follow these steps:https://help.ubuntu.com/community/Grub2/Installing#Reinstall_from_the_LiveCD)

Alright, now restart again. It should boot, but I got some errors at the begining which said "no suitable mode found" and "no graphics mode found". Apparently, this is something simple that has to do with fonts. Found this bug report https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/699802 and then used the workaround on comment #24 and viola. Now the system boots into 12.04 with no errors...it is using legacy booting...but it working for now at least.

I believe this can be fixed in the installation process of 12.04, but things are this way for now.


I had the same problem installing Linux Mint 17.1 (Ubuntu 14.04 base) on a Lenovo H430. I'm not sure why I didn't have any issues installing Linux Mint 15 on the same box a year-and-a-half ago, but I probably spent 10 hours trying to get Mint 17.1 to work. I tried ARR's own fix above, I followed steps outlined on several other web pages, I tried Boot-Repair. In the end, the ease of the fix was inversely proportional to the time I spent banging my head.

All I needed to do was to enable the Lenovo H430 CSM option (Compatibility Support Module) in the BIOS/UEFI (F1 on power up to enter UEFI). The other settings fell into place automatically. Then I rebooted and was actually a bit angry that it worked given the time I had invested on more complicated attempts at solving the problem. In the Startup tab of the UEFI my settings were

  • CSM [Enabled]
  • Boot Mode [Auto]
  • Boot Priority [Legacy first]
  • Quick Boot [Disabled or Enabled, either will work]
  • Rapid Boot [Disabled]
  • Boot Up Num-Lock Status [On] (shouldn't matter but included for completeness)
  • Keyboardless Operation [Enabled] (shouldn't matter but included for completeness)

I had made changes to Boot Mode and Boot Priority and Quick Boot several times in my attempts to get the new Linux install to boot. But without enabling CSM, nothing worked. If you have a Lenovo H430 and are having trouble installing Ubuntu or any other Linux, I would definitely recommend trying this setting. If you have a different computer but have a CSM option, this might work for you as well.

  • Switching to CSM in the UEFI settings as described above (but F12 for my computer) worked on my Lenovo Ideacentre Q190 with Ubuntu 16.04.3 server.
    – einnocent
    Dec 13, 2017 at 6:26
  • This is the way! CSM -> Enabled solved my problem. Thank you!
    – kchan
    Dec 24, 2023 at 2:27

You need a boot loader in the MBR in order to boot from the hard disk. The MBR is not in a partition of the disk, it's at the beginning in a special place. So when the installer asked you where to put GRUB, if you told it the same partition as Ubuntu, it won't be found.

Probably the easiest way to fix it is to use the GRUB Boot Repair Disk. My experience is that this will usually fix the problem automatically. I'd give it a try before trying anything complicated, unless you really want to learn a lot, and have a lot of patience or troubleshooting abilities.

  • unfortunately, this did not help. The problem likely has to do with ufei, which I think the new lenevo machines have...
    – ARR
    May 25, 2012 at 4:11

I had the same issue and the following worked for me:

  1. Run ubuntu from installation disk
  2. install and run boot-repair (you need internet access)

    sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update
    sudo apt-get install -y boot-repair && (boot-repair &)
  3. just choose the "Recommended Repair"

  4. boot from harddisk installation
  5. repeat steps 1-3
  6. restart.

it should work now.


I would suggest that you boot into the BIOS (usually it's F1 IRCC on ThinkCentes) and go to the SATA option and change it from AHCI to either IDE or Compatibility mode. I work at a place that has all ThinkCentres so if you're unable to find that option to configure the BIOS. Make a comment on the Model-Type (ie. 4329-ACU) and I'll check to see if we have that same model tomorrow and will edit this to include exact steps. I have had the same exact problem when taking a machine right out of the box and installing Ubuntu (regardless of release).

Hope this helps!

  • This is a 91p(4518-XF2)...I changed the SATA options to IDE, and still the same problem. I have put the HDD to be the first boot device in the 'primary' and 'automatic' boot sequence. Does changing it to IDE fix it for you all the time, or do you do something else as well?
    – ARR
    May 25, 2012 at 1:56

I had this same issue on a Lenovo ThinkCentre, but I needed to run in AHCI mode.

To fix the boot up error 1962, I went into the BIOS setup (held down F1 after starting), navigated to STARTUP and changed the BOOT MODE to UEFI. Now, every time I boot, it immediately boots into Windows 7 without errors.

I believe my MBR became corrupted (or lost entirely), but this method worked fine after restoring a backup image of the hard drive (which obviously wasn't 100% complete).


I just ran into the same problem installing 12.04.1 LTS on a Lenovo H430 machine.

So I installed it again using the above answers as clues and the statement: "[in retrospect, I could just have created those partions without installing 10.04, it seems]" in particular.

So rather than installing 10.04 first, I just deleted the existing partitions using manual partitioning in the installer first.

And then used a guided install to recreate the new partitions. Then when the install started it asked me if I wanted to create a new Master Boot Record and I said yes and now it boots into Ubuntu just fine.


I ran into that issue, and currently I'm (again). Error 1962. Now, I'm not using ubuntu (is my mom's pc), but since the issue is about the hardware, the OS doesn't make any difference. We bought the E1 thinkcentre on Jan/2013, 4 days after purchased the pc crashed. Lenovo exchange the HDD then but with w7 instead w8. A faulty lenovo technician tried install w8 but he failed and then for some reason the MOBO was damaged. Lenovo took the PC and 1 month and half later we got the PC back home with a new HDD and a new MOBO (according Lenovo). I powered up the pc and 4 hours later, guess what: 1962 again.

Using the logic, I thought, new HDD, new MOBO, should be the cable... or connectors, or definitely the MOBO.

Using the logic, I thought, new hdd, new mobo, should be the cable. I found something that confirms this suspects:


The cable Lenovo use is too tight and faulty. So it's a lenovo issue. They need find a solution exchanging the tipe of cable. Unfortunately for us under warranty we can't change the core components as we wish, that is a problem. We'll need stand.


On my machine, boot-repair experienced an error! Fortunately, I was able to successfully boot Ubuntu 14.04 on my Lenovo ThinkCentre by:

  1. Setting boot mode to legacy in BIOS.
  2. Booting Ubuntu LiveCD.
  3. Using gPartEd to delete all partitions.
  4. Using the Ubuntu installer, selecting the "Replace current operating system" option.

I had this problem with an ECS A75 board which BIOS was based on Lenovo. Apparently, most of Lenovo BIOS have this little issue that makes the UEFI boot always seek for the boot folders with same structure as in Windows 8.

I lost 3 days trying to figure out how to make Red Hat 6.5 boot properly after installation. Ok, RHEL have outdated Kernel and Ubuntu 13 already changed this, but in case someone still needs this solution, here goes how i solved it:

  • Boot to Live Ubuntu and then mount the boot partition;
  • Inside this partition there is one only folder, named [EFI]. Inside [EFI] folder, a subfolder named [REDHAT], containing the files [grub.conf] and [grub.efi]. Probably in Ubuntu this subfolder is named [UBUNTU];

  • On [EFI] folder you should duplicate the subfolder, whatever it is, and then rename this copy as [BOOT];

  • Now, inside the newly renamed [BOOT] folder you should rename the files to [Bootx64.conf] and [Bootx64.efi];
  • Unmount the partition and try to boot to your system now.

Let us know if this works for your problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .