4

I've got a new LG gram laptop (LG Electronics 17Z90Q-K.ADC9U1), running Ubuntu 22.04, fully encrypted disk using ZFS. Everything is working except when the computer wakes from suspend, the keyboard no longer works. I've included the output from libinput list-devices. I'm guessing the AT translation may be some kind of buffer translation from a UART device between the keyboard and cpu, but just a guess. My guess is this device is put to sleep, but not woken on power-up. I have to shutdown and power-up every time I store my laptop, so any help is appreciated. I've tried everything I can search online, but to no avail. Thanks

Device:           AT Translated Set 2 keyboard
Kernel:           /dev/input/event3
Group:            7
Seat:             seat0, default
Capabilities:     keyboard 

Edit: I have since tested the USB ports, and can confirm USB keyboards work on wake. From what I can see in the dmesg, it's an issue with the i8042 IC. I've tried editing all combinations of kernel grub options to no avail.

Edit 2: I figured out the fix. Turns out it was a thermal sensor that was the issue. Run sudo rmmod int3403_thermal to see if it stops the dmesg spam. If it does, insert acpi_mask_gpe=0x6E into /etc/default/grub.

8
  • As usual, update UEFI before anything else. Commented Jul 14, 2022 at 8:43
  • 1
    You could check if an external USB keyboard is affected on the same way or not... If not, it also would give control back to you, so you could investigate more after a resume.
    – redseven
    Commented Jul 14, 2022 at 8:52
  • @ChanganAuto - Correct me if I'm wrong but the only updates are for a couple windows drivers and lg software. link Or were you referring to something else?
    – user180977
    Commented Jul 14, 2022 at 9:16
  • 1
    @redseven - I can confirm the USB ports work on wake up. I've narrowed it down to a linux kernel issue that sends a sleep signal to the Intel i8042 IC, but is unable to wake it up. Tried multiple fixes, including adding grub entries to no avail, Any other ideas?
    – user180977
    Commented Jul 27, 2022 at 7:40
  • 1
    Sounds like you have enough info now to open a bug report for Ubuntu. But in my experience is not much better than asking a question here. ;)
    – redseven
    Commented Jul 27, 2022 at 12:48

2 Answers 2

2

The question is quite old but since I run into the same issue, this was my fix:

  • edit /etc/default/grub as admin and set the the variable GRUB_CMDLINE_LINUX_DEFAULT="quiet splash atkbd.reset"
  • update the grub configuration file with sudo update-grub
  • reboot the system

Hope this help.

2
  • If you check my last comment, you'll see I found a band aid solution for my issue. Thanks though
    – user180977
    Commented Apr 20 at 17:19
  • I did eventually run an EFI update, and that seemed to fix it. Thankfully I have a disk emulator now with the IODD to have a copy of windows at all times. Awesome device.
    – user180977
    Commented Apr 20 at 17:32
0
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.noaux"

worked for me on a VAIO running Ubuntu 23.04.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .