I'm on a dell studio 1749 x64. internal speakers work just fine. I have three jacks near the front,2 are for audio and 1 for input.

When I plug my speakers into the audio (headphone) jack(s) I get nothing.

I've tried the alsamixer, switching the sound card, making sure nothing was muted, etc. With alsamixer open, I've tried to force it to recognize by unplugging and replugging, and it then mutes the channel in alsamixer which is easy enough to change but it doesn't fix anything. I've also tried adding lines to alsa-base.conf, again nothing.

The added lines to .conf are as follows:

options snd-hda-intel model=dell, options snd-hda-intel model=STAC92xx, options snd-hda-intel model=dell-m81, options snd-hda-intel model=gateway, 

I know I only need 1 line but I'm not sure of my model so I left them all in there for extra measure. I thought they could be conflicting so I added (and rebooted) 1 at a time. No luck.

I'm on a fresh install of 12.04 LTS and I'll pastebin a log of any information needed.


Chaz solved in comments:

Adding options snd-hda-intel model=dell-m6-dmic to alsa-base.conf fixed my audio issue on Dell studio 1749 with IDT audio.

cat /proc/asound/card0/codec* | grep Codec spat out Codec: IDT 92HD73C1X5 Codec: Intel IbexPeak HDMI

From there I googled and it led me to the following where I found my answer:


  1. gksudo gedit /etc/modprobe.d/alsa-base.conf

  2. Add this line, options snd-hda-intel model=dell-m6-dmic

    or change options snd-hda-intel model=dell-m6-amic

    to options snd-hda-intel model=dell-m6-dmic

  3. Save the file, close gedit and reboot

  4. Test to see if working


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.