4

I installed Firefox from ppa:mozillateam/ppa but Netflix is not working and gives the error: "The WidevineCdm plugin has crashed".

I tried to use another user (a new user), I tried to disable and enable again drm, I tried it with no extensions, I tried to reinstall Firefox and install libavcodec-extra as suggested in other threads but nothing, always the same error.

I'm using Ubuntu 22.04 and Firefox version is 102.0.1 (64-bit).

Using the Snap version is not an option for me, I would rather change OS than using Firefox as a Snap, so I'm looking for a way to have a working Firefox installed with a .deb.

Edit:

Apparently the problem is related only to this version of Firefox. Firefox-ESR version 91.11.0 installed from the same ppa works perfectly, I think I will use this until the other is fixed.

3 Answers 3

2

Download it from the official site here and after that extract the tar and to run go into the Firefox directory and run the Firefox executable to make sure to works

  • then move the Firefox folder to ~/.local/lib (note if it does not exist, make it)
  • make a symlink with this mkdir -p ~/.local/bin/ ; ln -s ~/.local/lib/firefox/firefox ~/.local/bin/firefox
  • after that run this sudo sed -i 's/Exec=firefox/Exec=~\/.local\/bin\/firefox/g' /usr/share/applications/firefox.desktop
2
  • 1
    It works, confirming there is something wrong with mozillateam repository. It's a shame that I have to update it manually with this setup. Do you know if there is a way to get it from another repository?
    – Tommimon
    Jul 12, 2022 at 17:26
  • 1
    no firefox has a auto updater in it like windows
    – lnee
    Jul 12, 2022 at 19:19
2

Just occurred the same problem on Ubuntu 22.04 with Firefox from the official PPA. After googling for a bit I found out that the issue is caused by AppArmor that does not let to run Widevin plugin from your home directory - this was already reported 4 years ago (!) here - https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1777070

To fix the issue you need to edit the /etc/apparmor.d/usr.bin.firefox file and add

owner @{HOME}/.{firefox,mozilla}/**/gmp-widevinecdm//libso m,

to the # per-user firefox configuration section.

After that, you can reboot your computer (or reload AppArmor's rules with apparmor_parser --replace /etc/apparmor.d/usr.bin.firefox) and everything will be working just fine :)

I hope this will helpful so someone else

1
  • 2
    The command below worked for me, based on Skoruppa's link. owner @{HOME}/.{firefox,mozilla}/**/gmp-widevinecdm/*/lib*so m, Aug 24, 2022 at 20:50
2

I am not really fond of snap version of Firefox, so I am also using ppa:mozillateam/ppa on Ubuntu 22.10 and the problem really is related to AppArmor's Firefox config file.

I also edited /etc/apparmor.d/usr.bin.firefox but the recommended line by @skoruppa didn´t do the trick. Use this instead:

  1. bellow the line: # per-user firefox configuration

  2. write: owner @{HOME}/.{firefox,mozilla}/**/gmp-widevinecdm/**/libwidevinecdm.so m,

  3. After that, you can reboot your computer (or reload AppArmor's rules with apparmor_parser --replace /etc/apparmor.d/usr.bin.firefox).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.