I just upgraded to 12.04, with gnome classic no effects. Evernote worked ok on 11.04 and 11.10 with wine 1.3 configired as windows 7. I'm installing Evernote_4.5.6.6884.exe. The install works fine, but it can't connect. I'm getting an error in ssl:

err:wininet:NETCON_secure_connect SSL_connect failed: 12157

I've tried wine 1.3 and 1.4, configured as windows 7. I've installed libssl 0.9.8. I've tried using playonlinux. Play on linux gives extra information:

fixme:wininet:InternetAttemptConnect Stub
fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONNECT_TIMEOUT (15000): STUB
err:wininet:NETCON_secure_connect SSL_connect failed: 12157

Does anyone have a known good installation process for wine/evernote on 12.04?

[update] More info running from playonlinux from commandline:

/usr/share/playonlinux/playonlinux --run "Evernote"
[POL_System_CheckFS] Message: Checking filesystem for Evernote.exe
[POL_Wine] Message: Running wine- Evernote.exe 
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
[POL_Wine] Error: Wine seems to have crashed

If your program is running, just ignore this message
[POL_Wine] Message: Wine return: 2
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
[0524/134608:ERROR:network_change_notifier_win.cc(98)] WSALookupServiceBegin failed with: 8

Ok, i'll try to explain (sorry for my english, it's not native).

At first - install Evernote as usual.

When you finish - connection error will appear. It's ok. Close the application.

  1. Go to Play on Linux main menu -> Utilities -> wine versions managment.

  2. Install wine 1.4.1 (latest stable version with no ssl bug)

  3. Select Evernote and in settings choose wine version 1.4.1

And now it's ok! Evernote will work fine.

  • You may want to edit your answer to explain how to do this. – Eliah Kagan Jun 18 '12 at 22:41

This is caused by the fact that OpenSSL now supports TLSv1.1/1.2 but the Evernote 'server' does not; see here for more information and a patch that disables TLSv1.1/1.2 in Wine.

When before the commands below failed:

openssl s_client -connect www.evernote.com:443

Now the following will work correctly:

openssl s_client -connect www.evernote.com:443 -no_ssl2 -no_tls1_1 -no_tls1_2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.