0

I am really struggling with the Panel in Xubuntu 22.04 sometimes it just disappears, sometimes elements are missing,sometimes removing an element causes the panel to crash/disappear, I seem to have intermittent difficulty saving the panel setup etc. (if I try to save it nothing happens). So, I reinstalled the panel, and - as far as I understand it - removing the configuration : [see https://forums.linuxmint.com/viewtopic.php?t=344023]

xfce4-panel --quit   
pkill xfconfd    
rm -rf ~/.config/xfce4/panel      
rm -rf ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml    
xfce4-panel

after this the panel looked "new" , but am still getting a long error message, for example - after the panel disappeared again - running the command xfce4-panel leads to this output:

(wrapper-2.0:6872): GLib-GIO-CRITICAL **: 12:45:23.161: g_file_new_for_path: assertion 'path != NULL' failed
(wrapper-2.0:6872): GLib-GIO-CRITICAL **: 12:45:23.161: g_file_monitor_file: assertion 'G_IS_FILE (file)' failed
(wrapper-2.0:6872): GLib-GObject-WARNING **: 12:45:23.161: invalid (NULL) pointer instance
(wrapper-2.0:6872): GLib-GObject-CRITICAL **: 12:45:23.161: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
(wrapper-2.0:6872): Gtk-WARNING **: 12:45:23.161: Attempting to add a widget with type GtkToggleButton to a container of type XfcePanelPlugin, but the widget is already inside a container of type XfcePanelPlugin, please remove the widget from its existing container first.
** (wrapper-2.0:6873): WARNING **: 12:45:23.170: No outputs have backlight property
(wrapper-2.0:6868): Gtk-WARNING **: 12:45:23.201: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner GtkToggleButton)
(wrapper-2.0:6872): Gtk-WARNING **: 12:45:23.217: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner GtkToggleButton)
(wrapper-2.0:6874): Gtk-WARNING **: 12:45:23.258: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PulseaudioButton)
(wrapper-2.0:6871): Gtk-WARNING **: 12:45:23.271: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner GtkToggleButton)
(wrapper-2.0:6873): Gtk-CRITICAL **: 12:45:23.281: gtk_icon_theme_has_icon: assertion 'icon_name != NULL' failed
(wrapper-2.0:6873): Gtk-CRITICAL **: 12:45:23.281: gtk_icon_theme_has_icon: assertion 'icon_name != NULL' failed
(wrapper-2.0:6873): Gtk-CRITICAL **: 12:45:23.285: gtk_icon_theme_has_icon: assertion 'icon_name != NULL' failed
(wrapper-2.0:6873): Gtk-CRITICAL **: 12:45:23.287: gtk_icon_theme_has_icon: assertion 'icon_name != NULL' failed
(wrapper-2.0:6873): Gtk-WARNING **: 12:45:23.311: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PowerManagerButton)
2022-07-08T10:50:01.612846Z  INFO authenticator::application: Authenticator (com.belmoussaoui.Authenticator)
2022-07-08T10:50:01.614121Z  INFO authenticator::application: Version: 4.1.6 ()
2022-07-08T10:50:01.614126Z  INFO authenticator::application: Datadir: /app/share/authenticator
2022-07-08T10:50:05.175240Z  INFO authenticator::models::database: Running DB Migrations...
2022-07-08T10:50:05.175522Z  INFO authenticator::models::database: Database pool initialized.*

just to clarify, the panel is back after running xfce4-panel and it seems functional, occasionally some elements are missing (like weather plugin or Network applet), then running xfce4-panel -r sometimes solves the problem. Or I need to reinstall the Weather applet or Network applet.

Sorry forgot to mention initially - I may not have a "completely clean" installation of Xubuntu 22.04. I initially had a clean install, but then it kept crashing (which included some of the panel issues mentioned above already happening before installing Budgie), so I removed Xubuntu and installed as a "trial" Ubuntu Budgie, but then reverted back to Xubuntu via Timeshift when Budgie also "misbehaved".

However I think that panel preferences are in /home folder, which is not being backed up via Timeshift. so perhaps there is (still) conflict with "Budgie Settings" and XFCE/Xubuntu settings??

actually, under .config there were still 5 Folders like budgie-app-launcher budgie-control-center budgie-desktop budgie-extras and budgie-welcome. I deleted all of them. lets see what happens...

how do I solve this issue? thanks so much!

update 10 July. seems that removing the remaining budgie folders under .config made all the difference. so far so good...

1 Answer 1

1

Delete all the remaining budgie folders under .config that were left over from the "trial" Ubuntu Budgie installation.

  budgie-app-launcher
  budgie-control-center
  budgie-desktop
  budgie-extras
  budgie-welcome

1
  • yes, that was what I did and the problems with the Panel seemed to have disappeared 95%. thanks! Jul 10 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.