When I open Nautilus in ubuntu 12.04 gnome-session-fallback, it shows two tabs in the panel, one is my Nautilus, the other "starting home folder" (encircled green) stays there for 10-15 seconds and then disappears. I don't want it to appear. Anyone have any idea why this happens and can I have a solution for it?

enter image description here


I had this issue. I found there were two applications called "Files" in /usr/share/applications/ plus one called "Home Folder". The command for these was nautilus %u so I was pretty sure they had something to do with the problem. Anyway, removing these on their own didn't work, so this is what I did:

  1. Open terminal and type alacarte (this opens the menu for editing). Remove "Files" from the "Accessories" menu (it may be there twice, remove both). Close menu.
  2. Type sudo nautilus in terminal, navigate to /usr/share/applications/ and remove both "Files" and "Home Folder" applications.
  3. Log off and on again.
  4. Edit the menu as in step 1 and re-create the "Files" item with the command nautilus %u.
  5. Type nautilus in a terminal, pick any folder and right click on it, select "open with other application", then "browse", then choose the "Files" item you just created.

After step 3 you will not be able to open any folders unless you run the command nautilus in a terminal, steps 4 and 5 fix this.

This worked for me but I have no idea if it is the best/quickest/safest or stupidest way.


You can change the icon by editing the menu and clicking on the properties of the "File" entry. This will open a properties box with the icon in the top right corner, click on it and you can navigate to a new icon. I used /usr/share/icons/Humanity/places/32/folder.svg

Good tip about right clicking the icon to edit the menu, at last something is actually easier in gnome-classic!


  • I have the same issue and can confirm Drew's solution worked for me, just one comment and one additional question (if I may): Comment: step 1.: if you use gnome-classic, you can just right-click the menu bar and 'edit menu' Question (just a minor issue): the File icon has dissappeared in the menu and changed into a Tintin launcher rocket; how can I get the original icon back? There is also no entry 'file' in /usr/share/applications (?) Thanx for the solution, Drew. – Tinellus Jun 11 '12 at 9:16

This issue affects to gnome session (no classic) too, but there we don't see "starting home folder" there, we only see the busy mouse for thats 10-15 seconds. I discovered it's a login session issue, I don't know why, but when I have autologin it happens, and when I log manualy nautilus work fine.


Only use nautilus command without %U . It works for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.