10

When attempting to install Ubuntu on WSL, I get a "Something went wrong" error:

enter image description here

How should I troubleshoot/resolve this?

9
  • how did you install Ubuntu, exactly?
    – Esther
    Commented Jul 7, 2022 at 16:52
  • I installed it from the microsoft store which worked well, but on the wsl, it gives me an error Commented Jul 7, 2022 at 16:54
  • 1
    Open your command line (cmd.exe) as an administrator. Run the commands it tells you to in that error. Then reboot your system and try installing WSL again from the Microsoft Store. That error is not within the Ubuntu component but within the WSL component and there's not enough error output for us to really debug what went wrong.
    – Thomas Ward
    Commented Jul 7, 2022 at 16:56
  • @ThomasWard Actually, that's the new installer written by Canonical for Ubuntu 22.04 on WSL. They call it the "Out of Box Experience" (OOBE). Granted, it's entirely possible that the core problem is in WSL, but the installer that's erroring out is pure-Ubuntu. Commented Jul 7, 2022 at 17:24
  • @NiraliPatel (1) Start PowerShell, (2) Run wsl --shutdown (3) Run wsl --unregister Ubuntu-22.04. (4) Then run ubuntu2204.exe install --ui=none. You'll probably still get an error, but it will hopefully be more informative. Commented Jul 7, 2022 at 17:28

5 Answers 5

7

I ran into this while installing Ubuntu 22.04, and running the install via cmd showed me the solution that worked for me:

>  ubuntu2204.exe install --ui=none
Installing, this may take a few minutes...
WslRegisterDistribution failed with error: 0x800701bc
Error: 0x800701bc WSL 2 requires an update to its kernel component. For 
information please visit https://aka.ms/wsl2kernel

After installing the Linux kernel update package, the install worked normally. Re: https://docs.microsoft.com/en-us/windows/wsl/install-manual#step-4---download-the-linux-kernel-update-package

1
  • I had the same error as the OP. It was the Linux Kernel Update package in your link that fixed the error.
    – matohak
    Commented Aug 10, 2022 at 8:01
1

Make sure the Virtual Machine Platform Windows feature is enabled, virtualization is enabled in the BIOS, and you're running WSL2.

1
  • And like stated WSL2 kernel is upgraded. Commented Sep 11, 2022 at 15:44
1

I tried installing Debian for WSL and it showed me an error message that pointed to the URL mentioned above for the WSL kernel update: https://learn.microsoft.com/en-us/windows/wsl/install-manual#step-4---download-the-linux-kernel-update-package. After I applied the kernel update package Ubuntu installed without a problem.

0

Same error on my side. When running the command without UI, I see the real error :

PS C:\Users\ser> ubuntu2204.exe install --ui=none
Conversion in progress, this may take a few minutes...
For information on key differences with WSL 2 please visit https://aka.ms/wsl2
The requested operation could not be completed due to a virtual disk system limitation.
Virtual hard disk files must be uncompressed and unencrypted and must not be sparse.

Open %LOCALAPPDATA%/packages/ with the file browser, find the folder containing the Ubuntu package (CanonicalGroupLimited.Ubuntu22.04LTS_79rhkp1fndgsc in my case) and untick Compress contents to save disk space inside folder properties (Right Click -> Properties -> General -> Advanced)

Source: https://utf9k.net/blog/wsl2-vhd-issue/

0

I had the same error and abandoned it on WSL2 Windows11, so I downloaded Ubuntu 20.04 LTS from the Microsoft store, and it worked fine.

I figured it just wasn't ready for prime time.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .