35

I am a new Linux user. I installed Kubuntu 22.04 on a pc that previously run Windows 7. It was a clean installation, no dual-boot. Well, I managed to overcome the Nvidia issue, where the Kubuntu logo appears to freeze, by doing a 'Recovery boot' and installing all the updates. That went well and now I can log in to the system, but I get the following message on the screen, just after POST and before the Kubuntu logo appears as well as after the logo and before the log-in screen. After that, I can log in with no apparent problems.

This is the message I get:

mtd device must be supplied (device name is empty)

There was also a number at the beginning of the message but I didn't manage to take it down. I don't know if that's important.
I saved the log information to a file and I saw the same message in there too, but that's as far as I could get I'm afraid.

My question is this: Is that message trying to tell me something is seriously wrong and if that's the case what am I supposed to do to make it better?

EDIT
I have searched for information about mtd devices on Google but unfortunately all the sources I came across were in a language that I don't understand. I mean I don't have a degree in Electronics.
So, I simply shut down and then unplugged the computer, waited for a while and then plugged it in and booted again. The first time, the boot was message-free and I thought I had fixed it but I was wrong. After a 'reboot' the message was there again.
Then, I thought perhaps a file system check might correct the problem so I run fsck on the root device from the live usb but it did not find any errors. However, after that I now get 3 lines of the same message with different random numbers...
And I am totally confused!!! Help please?

EDIT 2
For the sake of completeness, here are the computer specs:

Motherboard: Gigabyte P55A-UD4 (rev 2.0)
BIOS: Award Software Intl, version F14
CPU: Intel Core i5 760 @ 2.80GHz
DISK: WDC WD10EZEX-00BBHA0
RAM: 8GB
GPU: NVIDIA GeForce GTS 450

This is a 12-year-old computer, which by contemporary standards is considered very old I guess. However, it has served me well over the years and the only things I had to replace were the PSU, about 5 years ago, and the hard drive, quite recently. I also updated the BIOS back in 2013. The computer is functioning well, no problems at all. In fact, I have another one with similar specs which is also performing very well. The only deficiency of those systems, always judging by contemporary standards, is that they have legacy BIOS. Personally, I don't see the benefit of UEFI bios for every day desktop users but that is another topic :)

Back to the question then, do you think there may be some conflict due to the fact that my BIOS is not UEFI? I am referring specifically to 'mtd' and 'fwupd' services. Are they actually necessary in my system-case? If not, can they be safely disabled/removed? I don't think I can update firmware on this system and to be honest I don't want to.

EDIT 3
This is now officially confirmed bug of medium importance. Reading through the bug report - link in the comments, below - it appears that

  1. The message is displayed due to a configuration issue of the mtdpstore module

  2. It is not related to failed boots

  3. It also shows on systems with UEFI enabled

  4. There is a proposed workaround available to remove the message

But I have not yet seen any references relating to the meaning of that message. Which mtd device was not supplied, for example, or why the device name was empty? Am I asking too much?

I know this is not about sending a rocket to space! In my humble opinion however, a stable LTS release should not rely on workarounds. Don't get me wrong, I like Ubuntu. It is working well with my hardware and I am happy using it except every now and then I have to deal with weird error descriptions which are rather annoying. To give another example, last year I had to suffer the abominable 'Failed to update metadata for lvfs...' message on my other computer for several months. I just hope this one does not take as long to fix.

7
  • 4
    Here's the bug report - bugs.launchpad.net/ubuntu/+source/systemd/+bug/1981622 At least you know it's not something you've done!:-)
    – Richard
    Commented Jul 18, 2022 at 8:36
  • @Richard Yes, I did see the report. I also noticed that the importance of the bug has not been decided and that it is not assigned to anyone yet. Nevertheless, there is a workaround offered for anyone interested. Thank you for posting the link.
    – pan
    Commented Jul 21, 2022 at 9:58
  • 2
    Had this problem (and technically still have it) what I did to boot into my system was get into grub menu > advance options, and choose the previous kernal "5.15.0-25-generic" > works fine, "5.15.0-41-generic" > this is broken for me Commented Jul 24, 2022 at 22:10
  • @user1845593 Good to hear that you worked it out. You are not the only one with system boot problems. Thanks for posting your solution as it might help others.
    – pan
    Commented Jul 25, 2022 at 2:59
  • 1
    Reading the Ubuntu Forum Thread: System can't start, "mtd device must be supplied" (askubuntu.com/questions/1417618/…) mentioned below, I used Ctrl+Alt+F2 and typed "apt install nvidia-driver-515" and rebooted. This solved the problem on my machine.
    – groussea
    Commented Aug 22, 2022 at 8:39

3 Answers 3

6

Hi @pan welcome on these forums :)

Just today I've started noticing the same message (on regular Ubuntu 22.04) so I guess it is related to a recent update. Have you noticed any problems since that message appeared? I have not, which suggests to me that you can safely conclude that it is "not a big deal" but of course that is not a guarantee.

Is your Kubuntu installed on an SSD?

On this thread https://ubuntuforums.org/showthread.php?t=2476796&page=2 it seems also Xubuntu users may see this message. And user allkhor suggest that backlisting the kernel module mtdpstore will get rid of the message. But it is unclear what other effects that blacklisting might have.

So if you are not seeing any problematic behaviour on your machine (specially related to disk operations) my advice would be to leave it as it is :)

4
  • Hi @user17254 Kubuntu is on a 1TB HDD, the only disk on this machine. I would not experiment with blacklisting kernels as that might cause further problems. At the same time, I am not sure what might happen next. That 'memory technology device' subsystem apparently handles flash memory, but it is an abstract concept few people understand which makes it all the more worrying when I see these messages. I think I'll go back to 20.04 for now and wait until the coast is clear ;)
    – pan
    Commented Jul 9, 2022 at 18:41
  • I installed 22.04 in a 20.04 VM. It seemed to work fine and even did apply maintenance. Now I am seeing that message myself. I tried installing it on a WD SSD and it jiust failed to boot.
    – Walt Corey
    Commented Jul 13, 2022 at 1:23
  • 2
    I have same message on Ubuntu server 22.04 virtualaized with VMware ESXI 7.0 U2 with BTRFS filesystem. My disks are SSD NVMe and VMs are working fine. I have same question, what this message trying to tell me?!
    – mehdiMj
    Commented Jul 14, 2022 at 6:47
  • Ubuntu 22.04.1 LTS virtualized through Unraid (QEMU+VNC+dGPU) returns the same error message (fresh install, no chance to apt update).
    – mgutt
    Commented Dec 31, 2022 at 12:23
6

In my case, I've found the solution here. In short:

  1. When you boot your PC, press and hold SHIFT.
  2. A window apears where you have to choose "advanced options for ubuntu...."
  3. you choose the (recovery-mode) of the newest kernel
  4. At the Recovery-menu you first choose network, hit enter - takes a few seconds
  5. After that you go to root (its the shell) and hit enter.
  6. Type the Following commands in:
apt-get update
apt-get upgrade -y
apt-get dist-upgrade -y
reboot

Seems that some updates in drivers, especially in Nvidia, were missing, blocking the kernel boot.

2
  • What does -y mean? Commented Nov 27, 2022 at 23:00
  • 3
    By default, apt install/upgrade will ask you if you are OK with the changes it'll make before making them. -y option allow to pre-answer YES to this question. linux.die.net/man/8/apt-get
    – Izaya
    Commented Nov 28, 2022 at 13:08
3

As mentioned here

This bug was fixed in the package systemd - 251.2-

As for 2022-09-15

Changed in systemd (Ubuntu Focal): status: Triaged → Fix Committed

Please expect update soon. As well as me...

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .