Installing the .deb 32-bit, I have this warning:

Dependendy is not satisfiable: libmysqlclient16 (>=5.1.21-1)

Have tried to apt-get install libmysqlclient16:

E: Package 'libmysqlclient16' has no installation candidate

And this apt-get install libmysqlcliente18 installed correctly but when trying to install MySQL Workbench again, I have the same error.


I have tried this but the result:

sudo gdebi mysql-workbench-gpl-5.2.40-1ubu1104-i386.deb 
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Building data structures... Done 
Building data structures... Done 
This package is uninstallable
Dependency is not satisfiable: libmysqlclient16 (>= 5.1.21-1)

EDIT Making the installation apt-get install mysql-workbench worked but installed an older version of it.

  • 1
    Hey there, Just out of curiousity, Did you need that newer or specific version of workbench? There is an existing version of workbench available in universe right now. Also the current existing version that may satisfy your dependency would now be: libmysqlclient18. Hope this helps!
    – itnet7
    May 24, 2012 at 18:31
  • 1
    I've installed the older version but I need the newer to avoid conflicts because I'm working with a team and they are using the last version, on Windows
    – user23907
    May 24, 2012 at 18:32

4 Answers 4


I used Daniel Mota's documentation a bit, but needed to modify some of his commands:

You can get the necessary mysql workbench deb here

First run the following:

sudo dpkg -i mysql-workbench-gpl-5.2.40-1ubu1104-i386.deb

As you know this will fail about the dependencies. Then wget and install the following:

wget https://launchpad.net/ubuntu/+archive/primary/+files/libzip1_0.9.3-1_i386.deb
wget http://launchpadlibrarian.net/94563300/libmysqlclient16_5.1.58-1ubuntu5_i386.deb

Next install:

sudo dpkg -i libzip1_0.9.3-1_i386.deb
sudo dpkg -i libmysqlclient16_5.1.58-1ubuntu5_i386.deb
  • If you're using 64bit, you'll want this instead:

    wget https://launchpad.net/ubuntu/+archive/primary/+files/libzip1_0.9.3-1_amd64.deb
    sudo dpkg -i libzip1_0.9.3-1_amd64.deb
    wget http://launchpadlibrarian.net/94808408/libmysqlclient16_5.1.58-1ubuntu5_amd64.deb
    sudo dpkg -i libmysqlclient16_5.1.58-1ubuntu5_amd64.deb

Then run the following:

sudo apt-get -f install python-paramiko libzip2 libmysqlclient18 mysql-client mysql-common python-pysqlite2 libdbi-perl libdbd-mysql-perl libplrpc-perl libnet-daemon-perl mysql-client

This too will fail, and ask you to re-run, just re-run it again:

sudo apt-get -f install

When that completes it should be installed for you, leave a comment if you run into any snags and I'll try and see if I can help you further.

Launch it once from either your terminal mysql-workbench or Unity Dash, once it's in the launcher, right click on it and select "Lock to Launcher".

I have not used this program to know whether or not it is stable after installation, YMMV.

Mysql Work Bench Installation Completed.

In the comments Peter K. let me know this was not working in Ubuntu 16.04. So here is the easiest way to get it working in Xenial. I still followed the link above to get the latest mysql workbench deb file (MySQL Workbench 6.3.7 at the time of this correction)

This is how I pulled it down and placed it in /tmp :

wget -P /tmp http://dev.mysql.com/get/Downloads/MySQLGUITools/mysql-workbench-community-6.3.7-1ubu1604-amd64.deb

I used the chmod command in order to make the .deb file executable, then used dpkg -i to install it (use sudo if you are not switched to root alread):

chmod +x /tmp/mysql-workbench-community-6.3.7-1ubu1604-amd64.deb
sudo dpkg -i mysql-workbench-community-6.3.7-1ubu1604-amd64.deb

You will see the failed dependencies:

dpkg: dependency problems prevent configuration of mysql-workbench-community:
 mysql-workbench-community depends on libtinyxml2.6.2v5; however:
  Package libtinyxml2.6.2v5 is not installed.
 mysql-workbench-community depends on libzip4 (>= 0.10); however:
  Package libzip4 is not installed.

To remedy this, use apt to help resolve (fix) the dependencies:

sudo apt-get -f install

This will show you the missing dependencies allowing for you to install them without any further steps.

The following additional packages will be installed:
  libtinyxml2.6.2v5 libzip4
The following NEW packages will be installed:
  libtinyxml2.6.2v5 libzip4

You should now be able to launch mysql-workbench in Xenial.

  • 1
    Friend, that worked like a charm =) Great solution. Thanks for your time
    – user23907
    May 24, 2012 at 20:31
  • 1
    No Problem!! I'm glad it worked for you!
    – itnet7
    May 24, 2012 at 20:55
  • 64-bit didn't work fails on /usr/libexec/mysql-workbench-bin: error while loading shared libraries: libgtkmm-2.4.so.1: cannot open shared object file: No such file or directory Nov 19, 2012 at 19:33
  • 1
    Works great in Ubuntu13.04 64bits
    – leticia
    Aug 9, 2013 at 12:54
  • ERROR: not works with UBUNTU 16 LTS Aug 5, 2016 at 2:04

This installed mysql-workbench 5.2 with all dependencies as of 20120531.

sudo apt-get install mysql-workbench
  • Worked great for me, but I needed dependencies so -f (--fix-broken) was necessary. Jul 17, 2012 at 17:20
  • Ubuntu 16.04 and workbench version 6.3.6 (Build: 511 CE) and it worked. Thanks! Jun 7, 2017 at 13:11

I found the package "mysql-workbench" in the default repository.

apt-cache search mysql-workbench

no additional config or hack needed, works for me


source: setupguides.blogspot.nl/

Install MySQL Workbench on Ubuntu 12.04

Currently there is no pre-built .deb file or repo available to install MySQL Workbench on Ubuntu 12.04. One will probably appear soon after official release of 12.04 but at the moment it is still in beta so there are a few extra steps to get it working.

NOTE: Once Ubuntu 12.04 moves out of beta there will probably be a better way of doing this so please check the official MySQL Workbench download page and the official 12.04 repos before attempting this.

First of all you will need to download the latest MySQL Workbench from here.

Next you must download a .deb file for libzip1 as it is not available in the 12.04 repos.

32 bit version - (https) launchpad.net/ubuntu/+archive/primary/+files/libzip1_0.9.3-1_i386.deb

64 bit version - (https) launchpad.net/ubuntu/+source/libzip/0.9.3-1/+build/1728114/+files/libzip1_0.9.3-1_amd64.deb for other architectures go here

After downloading just open them with the software centre and click install.

*NEW: The libmysqlclient16 package was removed from the 12.04 repos so you will need to download the old deb files for it:

32 bit version - launchpadlibrarian.net/94563300/libmysqlclient16_5.1.58-1ubuntu5_i386.deb

64 bit version - launchpadlibrarian.net/94808408/libmysqlclient16_5.1.58-1ubuntu5_amd64.deb

Next open a terminal and install the following packages:

sudo apt-get install libzip1 python-paramiko python-pysqlite2 libctemplate0 libgtkmm-2.4-1c2a libmysqlclient16

Then cd to the directory where you downloaded the deb file and run:

sudo dpkg -i mysql-workbench-gpl-5.2.38-1ubu1104-i386.deb

And that should be it, enjoy!

Instructions loosely based on those found here: blog.csdn.net/kevin6216/article/details/7420421


You must log in to answer this question.