1

I attempted to log in today and discovered that I had more users than I thought. It seems that both MS-SQL and RStudio users exist on my PC and are visible on my log-in screen. I've ran SQL on my laptop before, but only in a localhost setup that let me learn the language. Is there any good reason why I should have these users or any good reason why I shouldn't get rid of them?

Note that id -u mssql returns 997 and id -u rstudio-server returns 998.

6
  • How did you do your discovery? Are you seeing entries for them on the log in screen?
    – vanadium
    Jul 6 at 10:46
  • @vanadium Yes. Exactly that.
    – J. Mini
    Jul 6 at 10:46
  • Clarify your question to reflect that: use "edit".
    – vanadium
    Jul 6 at 11:51
  • @vanadium Already have.
    – J. Mini
    Jul 6 at 12:33
  • I see, great. What are the uids of these users? I guess they will be larger than 1000. You can hide them from GDM login screen as explained here: askubuntu.com/questions/2471/…
    – vanadium
    Jul 6 at 14:07

1 Answer 1

2
+50

The users shown at the greeter need to be at minimum (and the maximum UID_MAX) what is set in /etc/login.defs at UID_MIN.

The range 1–499 (Red Hat, CentOS) or 1–999 (Debian, Ubuntu) are reserved for system users, including users allocated when installing a package containing a system service that requires a dedicated user.

So your mssql user having 997 is correct. That user should, in default Ubuntu, not be shown at the greeter when it is below 1000.

Please check what your minimum is set to. To get rid of user 997 one methoud should be changing that parameter to something above 997. If it is 1000 this is a bug and should be reported against the greeter you use.

5
  • My login.defs has UID_MIN 1000 and UID_MAX 60000 (yes, with that crazy indentation. Is this certainly a bug? Is there anywhere that I can check for silly little things like some boolean that I might've accidentally set somewhere?
    – J. Mini
    Jul 11 at 21:01
  • @J.Mini yes it is a bug. It has happened before during beta that's why I believe it is a bug ;-) You could alter the id of mssql to <500 to test if that works (500 is the real default, Debian is the system that started using 1000)
    – Rinzwind
    Jul 12 at 7:03
  • Don't suppose you happen to know if this is fixed in 22.04? I could always just twiddle my thumbs until that upgrade comes through.
    – J. Mini
    Jul 12 at 19:14
  • I do not know that If you can I would advice using 22.04 over 20.04 but that is regardless of this issue ;-)
    – Rinzwind
    Jul 12 at 21:05
  • The issue has magically disappeared in 22.04.
    – J. Mini
    Aug 27 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.