I have a ryzen pc with an AMD Radeon Vega card, running ubuntu 22.04LTS, and I'm trying to install the amdgpu-install_22.10.2.50102-1_all driver so that I can use Blender 3.2 and have HIP support. However, I'm having a terrible time, and all my efforts have been for nought.

When I run the command amdgpu-install -y --opencl=rocr

I get the following ouput:

linux-headers-5.15.0-40-generic is already the newest version (5.15.0-40.43).
linux-headers-5.15.0-40-generic set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
apt : Depends: libapt-pkg6.0 (>= 2.4.5) but it is not going to be installed
grub-efi-amd64-signed : Depends: grub-efi-amd64-bin (= 2.06-2ubuntu7)
                     Depends: grub-efi-amd64 or
                              grub-pc but it is not going to be installed
init : PreDepends: systemd-sysv
libegl1-amdgpu-mesa : Depends: libudev1 but it is not installable or
                            libudev0 but it is not going to be installed
 libegl1-amdgpu-mesa-drivers : Depends: libudev1 but it is not installable or
                                    libudev0 but it is not going to be installed
 libgbm1-amdgpu : Depends: libudev1 but it is not installable or
                       libudev0 but it is not going to be installed
 libgl1-amdgpu-mesa-glx : Depends: libudev1 but it is not installable or
                               libudev0 but it is not going to be installed
 rocm-llvm : Depends: python but it is not installable
         Depends: libstdc++-5-dev but it is not installable or
                  libstdc++-7-dev but it is not installable
         Depends: libgcc-5-dev but it is not installable or
                  libgcc-7-dev but it is not installable
         Recommends: gcc-multilib but it is not going to be installed
         Recommends: g++-multilib but it is not going to be installed
 util-linux : PreDepends: libudev1 (>= 183) but it is not installable
 xserver-xorg-amdgpu-video-amdgpu : Depends: libudev1 (>= 183) but it is not 
Depends: xorg-video-abi-24 but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held 

I was under the impression that the driver was supported in Ubuntu 22.04LTS. I am new to Ubuntu so how do I get these installed if they're not installable, or is it all impossible?


6 Answers 6



amdgpu-install --usecase=opencl,graphics -y

The issue is that the default "usecase" includes hip, which isn't supported yet for 22.04 due to a python dependency issue. Installing only graphics (mesa) and opencl should be fine.


I have the same problem. Now I fixed.

check package files

dpkg -L amdgpu-install

here is key.

/etc/apt/sources.list.d/amdgpu.list /etc/apt/sources.list.d/rocm.list

there is an error/typo in these files.

Try changing from focal to jammy, as in "Jammy Jellyfish".

I installed successfully with below.

amdgpu-install --usecase=graphics,opencl --vulkan=amdvlk,pro


So, despite AMD releasing an official driver package for Ubuntu 22 they didn't actually make sure the dependencies were compatible. They are aware of this and have promised to fix it, you can follow that in these two issues, here and here.

Within one of these issue threads is the following workaround:

We are essentially going to download the rocm-llvm package, extract it, modify it, compile it again and then install it, fulfilling the dependencies the AMD Drivers need to install.

I didn't encounter the errors with libegl and libgbm1 so they might be related to something else or they may have been fixed by the latest amdgpu-install which I have: version 22.20.50200.

  1. Open a terminal, create a new directory and go into it. mkdir temp cd temp

  2. Download the rocm-llvm package apt download rocm-llvm. It's 695MB.

  3. Extract it ar x rocm-llvm_14.0.0.22204.50200-65_amd64.deb

  4. Extract control.tar.xz tar xf control.tar.xz

  5. Open control in a text editor gedit control

  6. Locate the line starting with Depends and replace it with this: Depends: python3, libc6, libstdc++6|libstdc++8, libstdc++-5-dev|libstdc++-7-dev|libstdc++-10-dev, libgcc-5-dev|libgcc-7-dev|libgcc-10-dev, rocm-core

  7. Save the file and close the editor.

  8. Rebuild control.tar.xz tar c postinst prerm control | xz -c > control.tar.xz

  9. Rebuild the .deb file ar rcs rocm-llvm_14.0.0.22204.50200-65_amd64.deb debian-binary control.tar.xz data.tar.xz

  10. Install new dependencies sudo apt-get install libstdc++-10-dev libgcc-10-dev

  11. Install the new .deb file sudo dpkg -i rocm-llvm_14.0.0.22204.50200-65_amd64.deb

  12. Install dependency for rocm sudo apt install rocm-core

  13. Download the latest Ubuntu Driver installer wget https://repo.radeon.com/amdgpu-install/22.20/ubuntu/jammy/amdgpu-install_22.20.50200-1_all.deb

  14. Install the latest Ubuntu Driver Installer. If it asks if you want to overwrite any sources files, you need to type Y so it will do this, if you've upgraded from 20.04 it is asking if you want to replace the old 20.04 sources with the new 22.04 versions.

  15. Run the driver installer again: sudo amdgpu-install --opencl=rocr -y

If at the end of installation it says

Error! Could not locate dkms.conf file.
File: /var/lib/dkms/amdgpu/ does not exist.
WARNING: amdgpu dkms failed for running kernel

Then run sudo dpkg-reconfigure amdgpu-dkms and it should resolve it.


I also ran into this issue after upgrading a machine to 22.04.1 LTS and using an older RX 580 GPU with kernel version 5.15.0-56. In case anyone out there is in my situation and comes here, as of this writing (Dec 2022), the following worked for me:

The -y and --accept-eula skips the EULA prompt and the apt prompt. --usecase=workstation, --opencl=rocr, and --vulkan=pro install options installs both graphics and OpenCL components, skipping the open-source vulkan. Finally, the --no-32 skips installing 32-bit components, which was also giving me issues on some attempts.

mesa-opencl-icd is required in order to get the library libMesaOpenCL.so.1 on my system. After installing this, I am able to see my GPU with clinfo -l:

$> sudo clinfo -l
Platform #0: AMD Accelerated Parallel Processing
Platform #1: Clover
 `-- Device #0: Radeon RX 580 Series (polaris10, LLVM 13.0.1, DRM 3.49, 5.15.0-56-generic)
Platform #2: Portable Computing Language
 `-- Device #0: pthread-Intel(R) Xeon(R) CPU E5-2670 0 @ 2.60GHz
  • Yours worked for me, thank you. I think I was running into an issue with no-32 in retrospect, because all the packages that wouldn't install were i386 architecture.
    – Jeremy
    Jan 18 at 23:55
  • this worked for me for ubuntu 22.04.. Now kdenlive hardware encoding works. Aug 14 at 9:06

If you browse in here https://repo.radeon.com/amdgpu-install/ to the latest drivers the repos are no longer named incorrectly. You'll still get the dependcy error if you dont specify your use cases as others have said. So install the latest one from there (november 22 release at the time of writing this) and then run this you should get a working driver: amdgpu-install --usecase=graphics,opencl --vulkan=amdvlk,pro


I messed around for hours today following errors, found AMD Community page with same error and good answer, that AMD has updated install package, but its not on main page. https://community.amd.com/t5/drivers-software/cannot-run-amdgpu-install-on-ubuntu-22-04-1/td-p/561053


worked for me with: amdgpu-install --usecase=opencl,graphics -y

Mint21 Vanessa & RX570

  • This adds nothing to the already existing answers. Plus, Mint is off-topic here. Dec 9, 2022 at 23:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .