8

Just bought a 1TB Element USB disk. I have several before and have had no problems. I have no problem using the new disk when connected to my laptop running ubuntu 18.04.

Here is the partition table (GPT)

(parted) print
Model: WD Elements 2621 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:
Number  Start   End     Size    File system  Name      Flags
 1      1049kB  1000GB  1000GB  ntfs         Elements  msftdata 
However, when I connect it to a desktop running a newly installed Ubuntu 22.04, the disk does not automount. As you can see below, I can mount it but no more: I get the information that the filesystem is read only and that I have no permissions for anything, like this:
$ sudo mount /dev/sdc1 /media/bjorn
$ ls /media/bjorn
ls: cannot open directory '/media/bjorn': Permission denied
$ sudo ls -al /media/bjorn
total 208
dr-x------ 1 root root   4096 jul  2 17:32 .
drwxr-xr-x 3 root root   4096 jul  1 20:44 ..
-r-------- 1 root root 202463 jul  2 17:32 TM-taket.jpg
$ sudo chmod 1755 /media/bjorn
chmod: changing permissions of '/media/bjorn': Read-only file system
$ sudo su
# chmod +r /media/bjorn
chmod: changing permissions of '/media/bjorn': Read-only file system
# sudo chmod +r /media/bjorn
# chown bjorn.bjorn /media/bjorn
chown: changing ownership of '/media/bjorn': Read-only file system
root@garage:/home/bjorn# 
What can I do? Make a new label and reformat?
1
  • Can you try to do a chkdsk on this disk on a Windows machine? If you do not have a Windows machine, you can try the ntfsfix command on Ubuntu; however it has very limited functionality.
    – FedKad
    Jul 3 at 10:53

1 Answer 1

14
  • it is an NTFS filesystem and that is Windows.
  • chmod is a Linux command so useless on Windows.
  • The mount command is not correct so that is more likely the problem ...
  • ... but if the NTFS filesystem is damaged (ie. dirty) Linux will never mount it writable to prevent data-loss. It is considered dirty if you can boot from a partition and let Windows hibernate it. Unlikely for an external USB but it can also happen with normal useage. Use Windows chkdsk to fix it. If it is due to hibernation you will need to disable it (from within Windows).

What can I do? Make a new label and reformat?

Options:

  • If the disk is not damaged and you want to stick with NTFS: You need to mount the partition to have write permissions. The command would be something like:

    sudo mount -o rw -t ntfs /dev/sdc1 /media/bjorn
    
  • If you do not have Windows or do not care for NTFS you can format the disk (use gparted for it; It will remove all contents of the disk) and make it ext4. If you do that you can do

    sudo chown $USER:$USER /media/bjorn
    

    and your current user will own the partition. If you have 2 or more users that need to use it put them in a group and change the second $USER to that group.

9
  • 1
    On the spot. I went for the second option, did exacly as suggested and have nor more problems.
    – sa0bxi
    Jul 3 at 15:06
  • @sa0bxi: ext4 isn't the only good option. For a single disk, btrfs is quite good, and has the reliability advantage of storing checksums for data and metadata. I'd definitely recommend reading up on the available filesystems and considering ones other than EXT4. Jul 3 at 23:14
  • 2
    Ubuntu 22.04: Why not use ntfs3?
    – iBug
    Jul 4 at 5:53
  • 1
    @PeterCordes ext4 is still the default filesystem for new installs. Which, if nothing else, means that if there are problems, there's more information out there on solving them.
    – James_pic
    Jul 4 at 11:09
  • 1
    @PeterCordes Stories aside, the NTFS3 driver is substantially better than the decades-old NTFS-3G project, which had more compatibility and stability issues, as well as sufferings from being a FUSE implementation.
    – iBug
    Jul 4 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.